Bug 598764

Summary: Deprecated file /etc/modprobe.conf
Product: [Fedora] Fedora Reporter: Ian Collier <imc>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 13CC: anaconda-maint-list, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-02 19:01:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ian Collier 2010-06-02 01:24:21 UTC
Description of problem:
I've just installed a Fedora 13 system on a blank disk from the DVD media (and updated it from the network).

If I "modprobe" a module, it says:

WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.

The file /etc/modprobe.conf exists and is blank on the new system.  I'm not sure who created it, but I didn't do it. :-)  So it would save a message if the install process didn't create that file.

Comment 1 Chris Lumens 2010-06-02 19:01:23 UTC
I just did a default install of F13 and anaconda did not create a /etc/modprobe.conf file.  Perhaps you have a package scriptlet that attempts to do something with this file and creates a blank new one if it's not present?

Comment 2 Ian Collier 2010-06-02 22:06:04 UTC
Sorry for the noise - it turns out to be system-config-network (bug 589593).

Comment 3 David Cantrell 2010-06-11 18:17:09 UTC

*** This bug has been marked as a duplicate of bug 589593 ***