Bug 589593 - saving settings in system-config-network generates empty /etc/modprobe.conf
saving settings in system-config-network generates empty /etc/modprobe.conf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
: Reopened
: 598764 (view as bug list)
Depends On:
Blocks: 606794
  Show dependency treegraph
 
Reported: 2010-05-06 10:03 EDT by Andre Robatino
Modified: 2010-09-30 06:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: system-config-network-1.6.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 606794 (view as bug list)
Environment:
Last Closed: 2010-09-04 01:16:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2010-05-06 10:03:20 EDT
Description of problem:
If I use system-config-network to change my ethernet connection to NOT be controlled by NetworkManager, then deactivate it, an empty /etc/modprobe.conf file is generated.  There shouldn't even be any code referring to this file anymore, AFAIK.  This may explain the mysterious empty modprobe.conf files that many people have seen, that cause warnings on boot.  The same thing happens on F12.

Version-Release number of selected component (if applicable):
system-config-network-1.6.0-2.fc14.noarch

How reproducible:
always

Steps to Reproduce:
1. Use s-c-n to edit ethernet connection so it's not controlled by NetworkManager.
2. Use s-c-n to deactivate the ethernet connection.
  
Actual results:
An empty /etc/modprobe.conf file is generated.
Comment 1 Andre Robatino 2010-05-22 16:22:39 EDT
Right after installing F13 (AKA RC3) I used s-c-n to edit the ethernet connection to add a DHCP hostname.  Upon saving I had an empty /etc/modprobe.conf file.  It seems that just about any use of s-c-n to edit network settings triggers this.
Comment 2 Andre Robatino 2010-05-27 23:35:32 EDT
Simplified procedure for reproducing: start s-c-n, then File/Save.  That's it.  The file /etc/modprobe.conf is immediately created.
Comment 3 Frank Murphy 2010-05-28 10:21:18 EDT
But, if you close the applet with the x.
It doesn't create /etc/modprobe.conf

or s-c-n-tui
doesn't create it either.
Comment 4 Andre Robatino 2010-05-28 16:34:03 EDT
Confirmed - if I run s-c-n-tui and immediately select "Save&Quit", it doesn't create the file.  Interesting.
Comment 5 David Cantrell 2010-06-11 14:17:09 EDT
*** Bug 598764 has been marked as a duplicate of this bug. ***
Comment 6 Jiri Popelka 2010-06-16 12:28:10 EDT
Fixed upstream (commit f6d58b7).
Comment 7 Bug Zapper 2010-07-30 07:33:47 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Fedora Update System 2010-08-23 09:47:00 EDT
system-config-network-1.6.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-network-1.6.1-1.fc13
Comment 9 Fedora Update System 2010-08-23 09:50:20 EDT
system-config-network-1.6.1-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/system-config-network-1.6.1-1.fc14
Comment 10 Andre Robatino 2010-08-23 09:59:41 EDT
This appears to fix the problem in F13.  Can't test in F14 or Rawhide since my VirtualBox guests currently don't work in graphical mode.
Comment 11 Fedora Update System 2010-08-23 15:02:22 EDT
system-config-network-1.6.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-network-1.6.1-1.fc14
Comment 12 Andre Robatino 2010-08-27 15:04:29 EDT
Appears to fix the problem in F14 and Rawhide as well, testing in KVM guests. Please submit an update for F12 as well. Thanks.
Comment 13 Fedora Update System 2010-09-02 16:43:38 EDT
system-config-network-1.6.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-09-03 05:02:00 EDT
system-config-network-1.6.1-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/system-config-network-1.6.1-1.fc12
Comment 15 Fedora Update System 2010-09-04 00:58:16 EDT
system-config-network-1.6.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/system-config-network-1.6.1-1.fc12
Comment 16 Fedora Update System 2010-09-04 01:16:02 EDT
system-config-network-1.6.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2010-09-30 06:33:14 EDT
system-config-network-1.6.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.