Bug 613976

Summary: polkit shows authentication dialog on display 0 not the desired one
Product: Red Hat Enterprise Linux 6 Reporter: Vladimir Benes <vbenes>
Component: polkit-gnomeAssignee: David Zeuthen <davidz>
Status: CLOSED CANTFIX QA Contact: desktop-bugs <desktop-bugs>
Severity: high Docs Contact:
Priority: low    
Version: 6.0CC: cmeadors, mclasen, ohudlick
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-13 13:59:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Vladimir Benes 2010-07-13 12:20:39 UTC
Description of problem:
when running vnc session from terminal from GNOME authenticating dialog shows itself on screen 0 not in the vnc session one. What more if I run vnc session with running Xorg authentication fails by default.
Hardcoded display 0? 

Version-Release number of selected component (if applicable):
polkit-0.96-2.el6.x86_64
polkit-gnome-0.96-3.el6.x86_64

How reproducible:


Steps to Reproduce:
1.open vnc session from GNOME
2.connect to the session
3.install package via add/remove software app
  
Actual results:
auth dialog shows on display 0

Expected results:
auth dialog shown on the same display as app needing it 

Additional info:

Comment 1 David Zeuthen 2010-07-13 13:59:40 UTC
This is a problem with VNC not properly registering with ConsoleKit. Since polkit relies on ConsoleKit having correct information available, this isn't something that can be fixed in polkit. I think bug 528511 is related to this.