Bug 616437

Summary: libguestfs missing runtime Requires: binutils
Product: [Fedora] Fedora Reporter: Richard W.M. Jones <rjones>
Component: libguestfsAssignee: Richard W.M. Jones <rjones>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: jzheng, mbooth, rjones, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: libguestfs-1.4.3-3.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 616438 (view as bug list) Environment:
Last Closed: 2010-08-30 14:28:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 616438    

Description Richard W.M. Jones 2010-07-20 09:16:29 EDT
Description of problem:

https://bugzilla.redhat.com/show_bug.cgi?id=615870#c8

The 'strings' program comes from binutils.  However libguestfs does
not Require: binutils, and in fact binutils is not pulled in indirectly
(although it is likely to be present on the system anyway).

Version-Release number of selected component (if applicable):

libguestfs in Fedora 12, 13, devel, EPEL 5
Comment 1 Fedora Update System 2010-07-20 09:48:24 EDT
libguestfs-1.2.10-1.1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libguestfs-1.2.10-1.1.fc12
Comment 2 Fedora Update System 2010-07-20 10:34:41 EDT
libguestfs-1.4.1-1.2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.4.1-1.2.fc13
Comment 3 Fedora Update System 2010-07-20 10:34:43 EDT
libguestfs-1.2.10-1.1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.2.10-1.1.el5
Comment 4 Fedora Update System 2010-07-21 16:00:44 EDT
libguestfs-1.2.10-1.1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libguestfs-1.2.10-1.1.el5
Comment 5 Jinxin Zheng 2010-07-22 07:00:53 EDT
$ rpm -qRp libguestfs-1.2.10-1.1.el5.x86_64.rpm  | grep binutils
binutils

$ rpm -qRp libguestfs-1.2.10-1.1.el5.i386.rpm | grep binutils
binutils

Since binutils requirement is added to these packages, I'm moving this bug to VERIFIED.
Comment 6 Bug Zapper 2010-07-30 08:42:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fedora Update System 2010-08-17 13:43:45 EDT
libguestfs-1.2.11-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libguestfs-1.2.11-1.fc12
Comment 8 Fedora Update System 2010-08-17 18:12:38 EDT
libguestfs-1.2.11-1.2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.2.11-1.2.el5
Comment 9 Fedora Update System 2010-08-17 18:13:02 EDT
libguestfs-1.4.2-1.1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.4.2-1.1.fc13
Comment 10 Fedora Update System 2010-08-19 17:59:48 EDT
libguestfs-1.2.11-1.2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libguestfs-1.2.11-1.2.el5
Comment 11 Jinxin Zheng 2010-08-19 23:09:16 EDT
# rpm -qRp libguestfs-1.2.11-1.2.el5.x86_64.rpm  | grep binutils
binutils

# rpm -qRp libguestfs-1.2.11-1.2.el5.i386.rpm | grep binutils
binutils

# rpm -qRp libguestfs-1.4.2-1.1.fc13.x86_64.rpm | grep binutils
binutils

# rpm -qRp libguestfs-1.4.2-1.1.fc13.i686.rpm | grep binutils
binutils

Both the fedora and epel versions require binutils now. Move to VERIFIED.
Comment 12 Fedora Update System 2010-08-27 15:27:50 EDT
libguestfs-1.4.3-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/libguestfs-1.4.3-3.fc13
Comment 13 Fedora Update System 2010-08-30 14:26:59 EDT
libguestfs-1.4.3-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/libguestfs-1.4.3-3.fc13
Comment 14 Fedora Update System 2010-08-30 14:27:51 EDT
libguestfs-1.2.11-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-09-03 17:57:17 EDT
libguestfs-1.2.11-1.2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2010-09-08 21:13:14 EDT
libguestfs-1.4.3-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.