Bug 615870 - libguestfs-find-requires.sh is not autogenerating dependencies for libguestfs
libguestfs-find-requires.sh is not autogenerating dependencies for libguestfs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks: 615946
  Show dependency treegraph
 
Reported: 2010-07-19 03:23 EDT by Jinxin Zheng
Modified: 2010-11-10 16:03 EST (History)
3 users (show)

See Also:
Fixed In Version: libguestfs-1.2.7-1.17.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 615946 (view as bug list)
Environment:
Last Closed: 2010-11-10 16:03:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Richard W.M. Jones 2010-07-19 06:45:17 EDT
Actually the problem is more serious: our custom dependency
generator (libguestfs-find-requires.sh) is no longer working,
not even in Fedora.  This apparently started after we moved to
using febootstrap-supermin-helper.
Comment 4 Richard W.M. Jones 2010-07-19 07:07:31 EDT
It's in the SRPM.  The Fedora equivalent script is here:

http://cvs.fedoraproject.org/viewvc/devel/libguestfs/

The problem is just that the path to 'hostfiles' moved, and
consequently it's not reading the correct file.
Comment 5 Richard W.M. Jones 2010-07-19 09:00:52 EDT
I think this bug should be a 6.0 blocker.  The fix is
a simple single-line change.
Comment 6 Richard W.M. Jones 2010-07-19 11:26:26 EDT
Build (ongoing):
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2607357
Comment 8 Richard W.M. Jones 2010-07-20 09:18:55 EDT
Jinxin, you are right again.  This is in fact another bug.

History: in bug 547496 we added the library dependencies.
We only added the library dependencies because binary dependencies
(eg. /sbin/e2fsck) are already taken care of in the specfile which
has a long list of 'Requires' lines.

However, the 'Requires' line is missing binutils, I guess because
we didn't realize that 'strings' is part of binutils, and also that
binutils wouldn't just be pulled in indirectly anyway.

So: I have opened another Fedora bug about this:
https://bugzilla.redhat.com/show_bug.cgi?id=616437
and I've cloned that bug for RHEL 6:
https://bugzilla.redhat.com/show_bug.cgi?id=616438

Please keep this bug for discussion of the library issue!
Comment 11 releng-rhel@redhat.com 2010-11-10 16:03:08 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.