This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 617123

Summary: Compatible resource group - left nav. tree do not show availability.
Product: [Other] RHQ Project Reporter: Filip Drabek <fdrabek>
Component: Core UIAssignee: RHQ Project Maintainer <rhq-maint>
Status: CLOSED WONTFIX QA Contact: Mike Foley <mfoley>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0.0CC: jshaughn, loleary, mazz
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-08 18:34:52 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 1069545    
Bug Blocks:    
Attachments:
Description Flags
Group left nav. tree with wrong availability rendering
none
Resource tree - shows availability DOWN
none
image showing inconsistency between folder icons and server/service icons
none
icons.png none

Description Filip Drabek 2010-07-22 05:21:18 EDT
Steps to Reproduce:
1) Install JON 2.3.1 and agent with Oracle 10g
2) Create compatible resource group 
   Recursive:  true 
   Category:  COMPATIBLE
3) Add a group member Linux - platform
4) Upgrade JON 2.3.1 to 2.4 
5) After upgrade new RHQ server will be discovered. The availability of the old one will go Down.

Actual results:
The old one RHQ server is shown in compatible group left nav. tree with availability UP. JBoss as JVM server and JBoss Cache subsystem server of that RHQ server has also availability UP. 

Expected results:
All of these resource are not running. The availability should be DOWN.

Additional info:
Comment 1 Filip Drabek 2010-07-22 05:23:01 EDT
Created attachment 433641 [details]
Group left nav. tree with wrong availability rendering
Comment 2 Filip Drabek 2010-07-22 05:24:28 EDT
Created attachment 433642 [details]
Resource tree - shows availability DOWN
Comment 3 Filip Drabek 2010-07-22 05:37:32 EDT
The group contains all resources but I can not see any of the alert definitions in group view - Alert tab.

These alerts were defined :
 (i) Create alerts:
       (a) Name:   Platform_alert_test    [Type: Linux (Platform)]
         If Condition:    Free Memory > 0.1B
         Dampening Rule:  Each time condition set is true
         Action Filters:  Disable alert until re-enabled manually or by    
         recovery alert: false
  Notify Roles (All Resources Role, Super User Role)
         Notify Other Recipients: Eamil - rtimaniy@redhat.com
  Operation- Control Type:   View Process List

        (b)Name:   JBOSSAS_JVM_ALERT [Type: JBoss AS JVM (Server)]
         If Condition:    Availability goes DOWN
         Dampening Rule:  Each time condition set is true
         Action Filters:  Disable alert until re-enabled manually or byrecovery 
         alert : false 
  Notify Roles (All Resources Role, Super User Role)
         Notify Other Recipients: Eamil - rtimaniy@redhat.com

        (c)Name:RHQ_Agent_JVM_Active_Threads_Alert  [Type: RHQ Agent(Server)]
         If Condition:    JVM Active Threads > -1.0
         Dampening Rule:  Each time condition set is true
         Action Filters:  Disable alert until re-enabled manually or byrecovery 
         alert: false 
         Notify Other Recipients: Eamil - rtimaniy@redhat.com
         Notify Roles (All Resources Role, Super User Role)
         Notify JON Users  (username - rhqadmin)

 (d) Name:   RHQ_Agent_alert_test    [Type: RHQ Agent (Server)]
         If Condition:    Total Memory > 0.1B
         Dampening Rule:  Each time condition set is true
         Action Filters:  Disable alert until re-enabled manually or by    
         recovery alert: false
  Notify Roles (All Resources Role, Super User Role)
         Notify Other Recipients: Eamil - rtimaniy@redhat.com
Comment 4 Charles Crouch 2010-07-22 09:22:37 EDT
Needs triage
Comment 5 Charles Crouch 2010-07-22 12:34:15 EDT
"Actual results:
The old one RHQ server is shown in compatible group left nav. tree with
availability UP. JBoss as JVM server and JBoss Cache subsystem server of that
RHQ server has also availability UP. "

The old RHQ server should be removed from inventory after upgrade as it is no longer a useable resource
Comment 6 Joseph Marques 2010-07-22 12:36:54 EDT
filip, can you explain in more detail what you were able to do prior to upgrade that you can't do after upgrade?

for groups, the alert>definition sub-tab will only show alert definitions defined on the group itself.  however, since alerts don't actually trigger at the group level, the alert>history sub-tab will display any alert that has fired on any resource that's a member of the group

does that explain what you were/are seeing?
Comment 7 Charles Crouch 2010-07-22 12:55:40 EDT
Filip, if you are seeing something which is not explained by the previous
comments please re-open this issue.
Comment 8 Charles Crouch 2010-07-23 12:41:23 EDT
Reopening and adding an attachment showing the latest issue. All the resources in the jboss as folder should be showing as down in the left nav, but only the folders are.
Comment 9 Charles Crouch 2010-07-23 12:42:54 EDT
Created attachment 434011 [details]
image showing inconsistency between folder icons and server/service icons
Comment 10 Charles Crouch 2010-07-23 15:57:53 EDT
Dropping the priority as this is not a regression, lukas will be filling in the details
Comment 11 Lukas Krejci 2010-07-23 16:21:07 EDT
Firstly, let me untangle the several aspects of this bug. There are basically 3 issues reported here:

1) The problem with alert definitions, which AFAICT is a non-issue.
2) The fact that the RHQ server is rediscovered after upgrade, which again is deemed not an issue.
3) The confusing rendering of the recursive compatible group tree.

So the only issue left to explain/fix here is 3).

The screenshots can make it appear as if we were looking at a common resource tree (rooted by a platform) but that's actually not the case (the one attachment showing the resource tree is here just to clarify the actual issue with the group tree).

The tree in question shows the contents of a recursive compatible group (with just a single member but that isn't important in this case, it just slightly add to the possible confusion). Therefore, the individual child nodes in the tree do not, per se, represent individual resources but rather something that we call clusters. Clusters are just sets of resources, each being a descendant of a different member of the actual group and sharing "similar" place in the members' resource subtrees.

In previous versions of RHQ, the group tree didn't show any availability hints. The availability of a cluster of resources was only available in its detail page. 

For RHQ 3 we introduced new icon set and made the clusters use the icons corresponding to the category of the constituent resources (i.e. server icon or service icon). The autogroups (i.e. the direct parents of the clusters) were in addition to icon change enhanced with the availability hint.

So the only issue left to solve in this bug is to add the availability hints to the clusters.
Comment 12 John Mazzitelli 2011-03-31 13:50:02 EDT
There are two issues that need to be addressed, but IMO will not be in time for RHQ4 release. I'm lowering the sev/prio of this issue and removing from the rhq4 blocking issue list because I don't think this is high severity.

The first issue to be addressed is the icons themselves. Today the GWT UI uses badged icons in the group tree: the icons let you know what kind of node you are looking at (either a Cluster Node, an Auto Type Group Node, or a Subcategory Node) and in the cluster node case, what type of resource cluster is represents (server or service). take a look at the icons.png attachment to see the four different icons.

Note that three are badged already (when a folder is unbadged, it is related to a subcategory of resource types, whereas when a folder is badged with the compatible group icon, it means it represents a Auto Type Group Node). So the question is, even if we had availability information, what would the icons look like? How do we add a second badge to these already-badged icons? We'd need UXD to provide input.

But there is a second problem that has already been alluded to -  we do not have availability information today in the GWT UI for the tree nodes. We'd have to code up some additional queries or server side APIs to obtain this and get the GWT tree code to use it. This would probably entail a large amount of potentially expensive queries. What would it mean to show a yellow badge (meaning some but not all) or a red badge (meaning all)? For subcategories, we'd have to query all the children for their avails to determine the type of avail badge. The same for the other types of nodes. Considering we could have hundreds or thousands of children, the query would need to be highly tuned for maximum efficiency.

Because we have not invested the time and effort to solve the above 2 issues, we need to push this issue. As it stands now, comment #11 describes the current state of the GWT group tree: "In previous versions of RHQ, the group tree didn't show any availability hints. The availability of a cluster of resources was only available in its detail page."
Comment 13 John Mazzitelli 2011-03-31 13:50:22 EDT
Created attachment 489185 [details]
icons.png
Comment 14 Jay Shaughnessy 2014-06-08 18:34:52 EDT
There is no plan to do this for the reasons above.