Bug 1069545 (JON3-8) - Put EAP subsystems into JON subcategories
Summary: Put EAP subsystems into JON subcategories
Status: CLOSED CURRENTRELEASE
Alias: JON3-8
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
(Show other bugs)
Version: JON 3.3.0
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: DR01
: JON 3.3.0
Assignee: Stefan Negrea
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 617123
TreeView+ depends on / blocked
 
Reported: 2014-02-25 09:16 UTC by Heiko W. Rupp
Modified: 2015-09-03 00:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 14:00:38 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EAP 6 resource tree does not match EAP 6 admin console (332.35 KB, image/png)
2014-08-08 13:10 UTC, Jan Bednarik
no flags Details
EAP 5 resource tree changes after the upgrade (186.21 KB, image/png)
2014-08-08 13:11 UTC, Jan Bednarik
no flags Details
EAP 6 resource standalone resource tree (102.71 KB, image/png)
2014-08-11 15:11 UTC, Jan Bednarik
no flags Details
EAP 6 domain resource tree (107.73 KB, image/png)
2014-08-11 15:11 UTC, Jan Bednarik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JON3-8 Critical Verified Put EAP subsystems into JON subcategories 2014-09-08 12:27:17 UTC
Red Hat Bugzilla 1069691 None None None Never

Description Heiko W. Rupp 2014-02-25 09:16:29 UTC
We need to put the resources of the EAP 6 plugin into subcategories to resemble the way the resources are laid out in the EAP console.

Comment 9 Stefan Negrea 2014-05-21 14:57:12 UTC
The pull request [1] for this feature has been merged into master branch.

The subcategory tree in RHQ should match the Configuration/Subsystems navigation menu from the EAP 6.3 admin console. The only exceptions to this rule are Infinispan, Messaging and Security sub-menus because the are no corresponding multiple sub-resources in the plugin. Also, any subsystems not listed in the EAP admin console will be children of the Subsystems sub-category without nesting.


The EAP tree should have the following subcategories for sub-resources:

Subsystems
--> Connector
--> Container
--> Core
--> Web



[1] https://github.com/rhq-project/rhq/pull/22

Comment 11 JBoss JIRA Server 2014-05-21 16:05:33 UTC
Heiko Rupp <hrupp@redhat.com> updated the status of jira JON3-8 to Resolved

Comment 13 Simeon Pinder 2014-07-31 15:49:44 UTC
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993

Comment 14 Jan Bednarik 2014-08-08 13:08:47 UTC
moving to ASSIGNED

Two test cases from TCMS test run https://tcms.engineering.redhat.com/run/165906/#caserun_6619827 failed.

Test case 384749:
After performing the upgrade from JON 3.2.0 GA to JON 3.3.0 DR01, the EAP 6 resource tree on remote agent stays the same as in version 3.2.0 GA and does not match the EAP 6 admin console, as required (see attached screenshot).

Test case 385013:
see BZ 1128131, see attached screenshot

Version:3.3.0.DR01
Build Number:6468454:dda0a47

Comment 15 Jan Bednarik 2014-08-08 13:10:15 UTC
Created attachment 925167 [details]
EAP 6 resource tree does not match EAP 6 admin console

Comment 16 Jan Bednarik 2014-08-08 13:11:23 UTC
Created attachment 925168 [details]
EAP 5 resource tree changes after the upgrade

Comment 19 Jan Bednarik 2014-08-11 15:10:31 UTC
moving to VERIFIED

The upgrade process was not performed correctly first time, I retested the issue and the test case 384749 (Resource subcategories resemble the way the resources are laid out in the EAP console after upgrade) now passes (see attached screenshots in next comments). So disregard Comment 15.

Test case 385013 (Resource tree for eap5 doesn't change after upgrade) still fails (see BZ 1128131), however JON 3-8 addresses EAP 6 so this rfe is verified.

Comment 20 Jan Bednarik 2014-08-11 15:11:14 UTC
Created attachment 925812 [details]
EAP 6 resource standalone resource tree

Comment 21 Jan Bednarik 2014-08-11 15:11:56 UTC
Created attachment 925813 [details]
EAP 6 domain resource tree


Note You need to log in before you can comment on or make changes to this bug.