Bug 620225 (CVE-2010-2788)

Summary: CVE-2010-2788 MediaWiki (< v1.15.5, v1.16.0): XSS in profileinfo.php
Product: [Other] Security Response Reporter: Jan Lieskovsky <jlieskov>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: axel.thimm
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-10-19 09:12:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 620226    
Bug Blocks:    

Description Jan Lieskovsky 2010-08-01 16:20:25 UTC
MediaWiki upstream has released:
  [1] http://lists.wikimedia.org/pipermail/mediawiki-announce/2010-July/000092.html

v1.16.0 and v.1.15.5 versions of MediaWiki, addressing the following XSS flaw (from [1]):

A cross-site scripting (XSS) vulnerability was discovered in
profileinfo.php. The vulnerability is only exposed when the script is
explicitly enabled in LocalSettings.php, with $wgEnableProfileInfo = true.

Comment 1 Jan Lieskovsky 2010-08-01 16:21:40 UTC
This issue affects the versions of the mediawiki package, as shipped
with Fedora release of 12 and 13.

Please fix.

Comment 2 Jan Lieskovsky 2010-08-01 16:23:37 UTC
Created mediawiki tracking bugs for this issue

Affects: fedora-all [bug 620226]