Bug 624951

Summary: 0.9.5 needs some upstream fixes for girparser
Product: [Fedora] Fedora Reporter: Yanko Kaneti <yaneti>
Component: valaAssignee: Michel Alexandre Salim <michel>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: bdpepple, michel
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 627418 (view as bug list) Environment:
Last Closed: 2010-08-25 20:24:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 620556, 627418    

Description Yanko Kaneti 2010-08-18 04:37:19 EDT
Description of problem:
valac from 0.9.5 generates broken code when using specific gir-s.
e.g. tp-lowlevel.gir from folks

Fixed by upstream commit 

commit fb5efa698bd06b82e6ed62b9613deadc3cbb7f2e
Author: Jürg Billeter <j@bitron.ch>
Date:   Tue Aug 17 21:02:43 2010 +0200

    girparser: Fix hidden parameters at the end of the parameter list
Comment 1 Yanko Kaneti 2010-08-18 09:03:30 EDT
Conveniently vala 0.9.6 was released today.
Comment 2 Yanko Kaneti 2010-08-19 06:41:01 EDT
and 0.9.7
Comment 3 Brian Pepple 2010-08-25 20:24:41 EDT
Built vala-0.9.7-1.fc15, and cloned (Bug #627418) for F14 since this is needed for Empathy-2.32.