Bug 627418 - 0.9.5 needs some upstream fixes for girparser
Summary: 0.9.5 needs some upstream fixes for girparser
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vala
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 624951
Blocks: 620556
TreeView+ depends on / blocked
 
Reported: 2010-08-26 00:19 UTC by Brian Pepple
Modified: 2010-09-16 03:50 UTC (History)
2 users (show)

Fixed In Version: vala-0.9.8-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of: 624951
Environment:
Last Closed: 2010-09-16 03:50:14 UTC


Attachments (Terms of Use)

Description Brian Pepple 2010-08-26 00:19:43 UTC
+++ This bug was initially created as a clone of Bug #624951 +++

Description of problem:
valac from 0.9.5 generates broken code when using specific gir-s.
e.g. tp-lowlevel.gir from folks

Fixed by upstream commit 

commit fb5efa698bd06b82e6ed62b9613deadc3cbb7f2e
Author: Jürg Billeter <j@bitron.ch>
Date:   Tue Aug 17 21:02:43 2010 +0200

    girparser: Fix hidden parameters at the end of the parameter list

--- Additional comment from yaneti@declera.com on 2010-08-18 09:03:30 EDT ---

Conveniently vala 0.9.6 was released today.

--- Additional comment from yaneti@declera.com on 2010-08-19 06:41:01 EDT ---

and 0.9.7

Comment 1 Brian Pepple 2010-08-26 00:21:11 UTC
Updated Vala is needed to build folks in F14, which is a requirement of Empathy-2.32.

Comment 2 Fedora Update System 2010-08-29 21:14:14 UTC
folks-0.1.14.1-1.fc14,libgee-0.5.2-2.fc14,vala-0.9.7-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/folks-0.1.14.1-1.fc14,libgee-0.5.2-2.fc14,vala-0.9.7-1.fc14

Comment 3 Fedora Update System 2010-08-30 19:39:44 UTC
folks-0.1.14.1-1.fc14, libgee-0.5.2-2.fc14, vala-0.9.7-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update folks libgee vala'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/folks-0.1.14.1-1.fc14,libgee-0.5.2-2.fc14,vala-0.9.7-1.fc14

Comment 4 Fedora Update System 2010-09-14 16:08:58 UTC
vala-0.9.8-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/vala-0.9.8-1.fc13

Comment 5 Fedora Update System 2010-09-15 05:42:31 UTC
vala-0.9.8-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vala'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/vala-0.9.8-1.fc13

Comment 6 Fedora Update System 2010-09-15 13:33:33 UTC
gedit-vala-0.9.3-1.fc14,vala-0.9.8-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gedit-vala-0.9.3-1.fc14,vala-0.9.8-1.fc14

Comment 7 Fedora Update System 2010-09-16 03:50:01 UTC
vala-0.9.8-1.fc14, gedit-vala-0.9.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.