Bug 627116

Summary: screen garbage on xterms while using compiz on intel mobile 915 graphics
Product: [Fedora] Fedora Reporter: Alan <chekov>
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: ajax, mlichvar, pertusus, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-19 13:10:17 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
streaking on the desktop
an xterm with gargled text
this is all I have in my /etc/X11/xorg.conf.d folder catted into one file
X server log file
output of dmesg
/var/log/messages file none

Description Alan 2010-08-25 02:34:28 EDT
Created attachment 440841 [details]
streaking on the desktop

Description of problem:
This may be related to bug 577142
Whenever I launch an xterm process I get a window in which the text is messed up.  Rows of text will not all be the same height, and as the color block cursor advances to the right it "drips" color such that the rightmost characters are illegible.  Control-clicking for a menu causes that menu to leave residual vertical and horizontal lines, and sometimes dragging the entire xterm window around leaves streaks on the desktop.

Changing the text font (VT Font in the control-right click menu) eliminates the problem from that xterm for the rest of the session (any size change, even if I change it back).  It only seems to affect xterm windows though I assume it is a bug in mesa, xorg dri drivers or compiz...

Version-Release number of selected component (if applicable):

How reproducible:
always on my laptop, haven't tested other hardware.  I assume there's some dependency on the graphics chipset.

Steps to Reproduce:
1.  Set up Gnome with Compiz on hardware using Mobile GM965/GL960 Integrated Graphics Controller
2.   start an xterm
3.   type text inside of it and move the window around.
Actual results:
garbled/compressed text, residiaul lines, garbage on screen

Expected results:
clean text rendering and motion

Additional info:
lots of other things may be relevant but I just don't know.  I have the wobbly windows effect turned on in compiz, for one.  I'm including all of my .Xdefaults that relate to xterm just in case:
XTerm*BorderWidth:              2
XTerm*reverseWrap:              true
XTerm*Background:               white
XTerm*BodyFont:                 8x13
XTerm*cursorColor:              orange
XTerm*Border:                   red
XTerm*Panespread:               .25
XTerm*SaveLines:                5000
XTerm*autoWrap:                 true
XTerm*cutNewline:               true
XTerm*cutToBeginningOfLine:     true
XTerm*alwaysHighlight:          false
XTerm*c132:                     false
XTerm*jumpScroll:               true
XTerm*loginShell:               false
XTerm*marginBell:               false
XTerm*multiScroll:              true
XTerm*reverseVideo:             false
XTerm*resizeGravity:            SouthWest
XTerm*scrollBar:                false
XTerm*scrollTtyOutput:          false
XTerm*scrollKey:                true
XTerm*signalInhibit:            false
XTerm*visualBell:               false
XTerm*waitForMap:               false
XTerm*zIconBeep:                1
XTerm*trimSelection:            true
XTerm*colorULMode:              true
XTerm*colorUL:                  forest green
XTerm*underLine:                true
XTerm*veryBoldColors:           2
XTerm*boldColors:               true
XTerm*utf8:                     1
XTerm*locale:                   medium
XTerm*wideChars:                true
XTerm*renderFont:               true

I tried to take screenshots of the
Comment 1 Alan 2010-08-25 02:34:57 EDT
Created attachment 440842 [details]
an xterm with gargled text
Comment 2 Miroslav Lichvar 2010-08-25 06:08:38 EDT
This looks like a driver problem, reassigning to xorg-x11-drv-intel.
Comment 3 Matěj Cepl 2010-08-27 22:38:38 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Alan 2010-08-30 20:02:31 EDT
Created attachment 442059 [details]
this is all I have in my /etc/X11/xorg.conf.d folder catted into one file
Comment 5 Alan 2010-08-30 20:04:48 EDT
Created attachment 442060 [details]
X server log file
Comment 6 Alan 2010-08-30 20:05:48 EDT
Created attachment 442061 [details]
output of dmesg
Comment 7 Alan 2010-08-30 20:08:19 EDT
Created attachment 442062 [details]
/var/log/messages file
Comment 8 Adam Jackson 2010-11-19 13:10:17 EST
Actually a compiz bug, not an intel driver bug.

*** This bug has been marked as a duplicate of bug 614542 ***