Bug 614542 - xterm graphical corruption when compiz is active
Summary: xterm graphical corruption when compiz is active
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Adel Gadllah
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch, Reopened
: 627116 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-14 17:56 UTC by Richard Allen
Modified: 2011-02-15 21:28 UTC (History)
15 users (show)

Fixed In Version: compiz-0.8.6-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-15 21:28:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of XTerm corrupted (2.12 KB, image/png)
2010-07-14 17:59 UTC, Richard Allen
no flags Details
Another screenshot (2.85 KB, image/png)
2010-07-14 18:01 UTC, Richard Allen
no flags Details
this one is showing badness in characters. (14.50 KB, image/png)
2010-08-08 19:29 UTC, Paul Rolland
no flags Details
This one is OK, horizontal resizing was done before. (14.44 KB, image/png)
2010-08-08 19:30 UTC, Paul Rolland
no flags Details
Black blocks instead of characters (356.31 KB, image/png)
2010-12-02 19:51 UTC, Hicham HAOUARI
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 635258 None None None Never

Description Richard Allen 2010-07-14 17:56:24 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.4) Gecko/20100622 Fedora/3.6.4-1.fc13 Firefox/3.6.4

when Compiz is switched on, xterm starts to corrupt everything inside it's window. However, If another windows moves over the xterm and away again (backingstore) the corruption is fixed.

Reproducible: Always

Steps to Reproduce:
1. Enable compiz
2. Start XTerm
3. type something. Sometimes it takes 2 or 3 commands before it goes
Actual Results:  
Corrupted, unreadable xterm

Expected Results:  
Nice and clean XTerm

[ra@morticia ~]$ rpm -q xterm
xterm-256-1.fc13.i686

I rebuild the xterm in Rawhide (the f14 one) with no change.

Comment 1 Richard Allen 2010-07-14 17:59:34 UTC
Created attachment 431861 [details]
Screenshot of XTerm corrupted

Comment 2 Richard Allen 2010-07-14 18:01:56 UTC
Created attachment 431862 [details]
Another screenshot

Comment 3 Richard Allen 2010-07-14 18:02:41 UTC
Using gnome on a fully updated F13 machine.

Comment 4 Dave Botsch 2010-07-31 03:49:55 UTC
I'm seeing something similar with compiz. When typing in xterm, I'm getting these vertical bars to the left of the letters. Works fine w. metacity (compositing on or off).

Comment 5 Dave Botsch 2010-07-31 03:50:33 UTC
Oh, yes. FC13, 64-bit, fully updated.

Comment 6 Dave Botsch 2010-07-31 04:48:05 UTC
of interest, if I drag to resize the xterm, the "glitches" while typing go away. If I then drag to resize the xterm to the original size, there are also no longer any glitches.

Comment 7 Paul Rolland 2010-08-08 19:27:38 UTC
I've to add a "me too" to this bug.
My config is :
F13 64bits, compiz, emerald, all packages up to date as of Aug, 8th 2010.
Switching back to KDE default window manager (kwin --replace) and newly started xterm are Ok.

I can also confirm that resize horizontally the xterm window (expand from 80 chars wide to 81 and then back to 80) fixes the problem.

I attach two small screenshots I took, of a "vi" window containing characters that help show the problem. 
Using gimp to measure the window shows a difference of 2 pixels of the width of the inner rectangle in which characters are drawn.

Comment 8 Paul Rolland 2010-08-08 19:29:04 UTC
Created attachment 437470 [details]
this one is showing badness in characters.

Comment 9 Paul Rolland 2010-08-08 19:30:01 UTC
Created attachment 437472 [details]
This one is OK, horizontal resizing was done before.

Comment 10 Paul Rolland 2010-08-26 13:19:01 UTC
I "fixed" (workaround) the XTerm issue by creating a file in my home named .Xdefaults and inserted the following text in it :

! For XTerm.... We need to do that because when using the default borderWidth
! (1), then compiz is confused, and Window width is not accurate (off by 2).
XTerm*borderWidth: 0

This is merge with my other X resources at session opening time and prevent xterm from creating an inner colored rectangle which is by default 1 pixel.

/me now wondering if the bug is in Xterm or not...

Paul

Comment 11 Dave Botsch 2010-08-27 02:55:43 UTC
Just tried the workaround mentioned in comment 10. This workaround "works" for me as well.

Comment 12 Paul Donohue 2010-10-17 13:08:22 UTC
Same bug affects Ubuntu as well:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/635258

Comment 13 Paul Donohue 2010-10-17 15:06:42 UTC
The bug appears to have been introduced by:
http://git.compiz.org/compiz/core/commit/?h=compiz-0.8&id=6d4833f0e3217c63f516acbdc90796b4d78eecfb

The bug is fixed either by reverting that commit or changing the added lines to:
w->width = attr.width + (attr.border_width * 2);
w->height = attr.height + (attr.border_width * 2);

I'm currently unable to get to http://bugs.opencompositing.org/ so I have not filed an upstream bug report.

Comment 14 Paul Donohue 2010-10-17 18:37:16 UTC
Patch has been committed upstream:
http://git.compiz.org/compiz/core/commit/?h=compiz-0.8&id=0f95c41a0aa175ddf7947ba18b01f746c95594a9

Comment 15 Pritam Dodeja 2010-11-17 01:39:55 UTC
I was able to fix this issue by doing the following:

Applying upstream fix mentioned above
Changing all references to gdk_display to gdk_display_get_default in BUILD/compiz-0.8.6/gtk/window-decorator/gtk-window-decorator.c

and rebuilding with rpmbuild -bb SPEC/compiz.spec

I am currently using the rpm and don't see the error, however, I do not know if this introduces new errors.

Comment 16 Adam Jackson 2010-11-19 18:10:17 UTC
*** Bug 627116 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2010-11-30 13:22:16 UTC
compiz-0.8.6-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/compiz-0.8.6-5.fc14

Comment 18 Fedora Update System 2010-11-30 22:18:30 UTC
compiz-0.8.6-6.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update compiz'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/compiz-0.8.6-6.fc14

Comment 19 Hicham HAOUARI 2010-12-02 19:51:50 UTC
Created attachment 464350 [details]
Black blocks instead of characters

Comment 20 Hicham HAOUARI 2010-12-02 19:52:54 UTC
I am having black blocks instead of characters, as show in the screenshot, however this are removed with a minimize/restore.

Maybe it is a driver bug.

Comment 21 leigh scott 2010-12-02 20:12:20 UTC
(In reply to comment #20)

> 
> Maybe it is a driver bug.


I'm unable to reproduce the bug with the updated package, what driver are you using?

Comment 22 Hicham HAOUARI 2010-12-02 20:19:48 UTC
(In reply to comment #21)
> (In reply to comment #20)
> 
> > 
> > Maybe it is a driver bug.
> 
> 
> I'm unable to reproduce the bug with the updated package, what driver are you
> using?

r300g

Comment 23 Fedora Update System 2010-12-12 20:03:24 UTC
compiz-0.8.6-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Christian Krause 2011-01-29 16:59:28 UTC
I'll re-open this bug report because the issue is still present in F13.

I have tried the already built compiz package which contains the correct patch:
https://koji.fedoraproject.org/koji/buildinfo?buildID=205340
and it works perfect. Please can you push it out as an official update for F13?

Thank you very much in advance!

Comment 25 Fedora Update System 2011-01-29 17:18:13 UTC
compiz-0.8.6-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/compiz-0.8.6-2.fc13

Comment 26 leigh scott 2011-01-29 17:22:45 UTC
(In reply to comment #24)
> I'll re-open this bug report because the issue is still present in F13.
> 
> I have tried the already built compiz package which contains the correct patch:
> https://koji.fedoraproject.org/koji/buildinfo?buildID=205340
> and it works perfect. Please can you push it out as an official update for F13?
> 
> Thank you very much in advance!

Pushed to testing

https://admin.fedoraproject.org/updates/compiz-0.8.6-2.fc13

Comment 27 Fedora Update System 2011-01-30 19:52:06 UTC
compiz-0.8.6-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update compiz'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/compiz-0.8.6-2.fc13

Comment 28 Fedora Update System 2011-02-15 21:27:55 UTC
compiz-0.8.6-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.