Bug 627149

Summary: system.listPackages fails when install time is null
Product: Red Hat Satellite 5 Reporter: Tomas Lestach <tlestach>
Component: UpgradesAssignee: Tomas Lestach <tlestach>
Status: CLOSED CURRENTRELEASE QA Contact: Šimon Lukašík <slukasik>
Severity: medium Docs Contact:
Priority: medium    
Version: 540CC: cperry, jhutar, msuchy, slukasik
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: Fixed in the 5.4.0 Release - GA'd 2010-10-27
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-28 15:04:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 608757    

Description Tomas Lestach 2010-08-25 08:26:35 UTC
Description of problem:
provide an upgrade script for rpm installation dates

There's an upgrade script that adds the installtime column to the rhnServerPackage table, but no script that would set the installtime to a not null value for already registered clients.
null installtime values can cause troubles to API call system.listPackages, since xmlrpc cannot pass null values.

Version-Release number of selected component (if applicable):
upgrade from sat530 to sat540

Additional info:
suggested script:
UPDATE rhnServerPackage SET installtime = created WHERE installtime IS null;

Comment 1 Tomas Lestach 2010-08-25 08:36:04 UTC
upgrade script added into spacewalk/schema/spacewalk/upgrade/spacewalk-schema-1.1-to-spacewalk-schema-1.2 directory

spacewalk.git: 376771d95de9c620f925b3938f27662389301c44

Comment 2 Tomas Lestach 2010-08-30 11:24:43 UTC
Agreed on satellite-devel that it's better not to include a null installtime item, than to set some value to the DB via an upgrade script

spacewalk.git: c122bd485b19c27b3338af682bbf50798bfef5f6

Comment 4 Šimon Lukašík 2010-10-06 14:16:18 UTC
Changing to VERIFIED:

Test procedure:
1)
- Register clients to sat530, upgrade to sat540
- Api call should not return key 'installtime' within the dict
- Webui should report "not specified"
- rhn-profile sync
- should return item 'installtime' within the dict
- webui should report same dates
2) 
- Registered clients with older rhnlib into sat540
- rest is the same as per 1)
3) Behaviour and documentation matches
4) Dates seems to be correct


Verified against:
Satellite-5.4.0-RHEL5-re20101001.1

Special thanks to Martin.

Comment 5 Clifford Perry 2010-10-28 15:04:00 UTC
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford