Bug 628786

Summary: emphasis, citetitle, and xref don't render in Japanese PDFs
Product: [Community] Publican Reporter: Ruediger Landmann <r.landmann>
Component: publicanAssignee: Ruediger Landmann <rlandman>
Status: CLOSED CURRENTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: high Docs Contact:
Priority: medium    
Version: 1.6CC: ccheng, etowns, jfearn, lijli, mmcallis, mospina, noriko, pcormier, publican-list, r.landmann, ykatabam
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 3.0.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-23 17:56:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Sample FO file none

Description Ruediger Landmann 2010-08-30 23:44:30 EDT
Description of problem:
Japanese text in the <emphasis> and <citetitle> tags doesn't render in PDF. If the title of a section or chapter contains Japanese text, the title does not appear when presented in xrefs.

Version-Release number of selected component (if applicable):
2.1

How reproducible:
100%

Steps to Reproduce:
1. Include a string that includes <emphasis> and <citetitle> in a Japanese text
2. run publican build -f pdf -l ja-JP
  
Actual results:
The text is invisible in some PDF viewers or appears as a row of empty boxes in others.

Expected results:
Japanese text is rendered. 

Additional info:
Sample text for testing:

You <emphasis>must</emphasis> refer to the <citetitle>Configuration Guide</citetitle>.

<citetitle>設定ガイド</citetitle>を参照<emphasis>しなければなりません</emphasis>。
Comment 1 Ruediger Landmann 2010-08-31 00:14:49 EDT
Created attachment 442088 [details]
Sample FO file
Comment 2 Chester Cheng 2010-09-28 22:22:01 EDT
Hi,

This also happens in Traditional Chinese.  I use RHEL5/publican 2.1-0.el5.

Change Severity to High, since the meaning of the contents can be totally different, such as "This is <emphasis>not</emphasis> recommended." will be rendered as "This is    recommended."

Regards,
Chester
Comment 3 Jeff Fearn 2010-09-29 04:29:37 EDT
Hi, I've tested a fix for this but the fix is very invasive :( Basically the problem is that FOP seems to think the localised fonts are not providing italic characters, and they might to be, so it is falling back to fonts that do provide italic characters. Unfortunately the fall back fonts don't provide Japanese characters, so the missing/garbled text gets displayed.

The work around is to remove the non localised fonts from the font list, so FOP falls back to the normal type face, but this requires not only removing the Liberation fonts, but the Symbol and ZapfDingbats fonts as well.

Please QA the following PDF [1] which was built from a recent check out of the RHEL6 IG [2]

[1] http://file.bne.redhat.com/~jfearn/Red_Hat_Enterprise_Linux-6-Installation_Guide-ja-JP.pdf

[2] https://svn.devel.redhat.com/repos/ecs/Red_Hat_Enterprise_Linux/6.0/FINAL/Installation_Guide
Comment 4 Jeff Fearn 2010-09-29 04:31:12 EDT
(In reply to comment #3)

> characters, and they might to be, so it is falling back to fonts that do

might NOT be ... d'oh!
Comment 5 Jeff Fearn 2010-09-29 23:17:39 EDT
This is due to the fonts not containing bold or italic glyphs, I reverted to the old behaviour of specifying font metric files for ja-JP, zh-CN, zh-TW and ko-KR fonts, this way we can force FOP to use the same font for all weights and styles.

Fixed in Build: 2.1-0%{?dist}.t119
Comment 6 Fedora Update System 2010-10-06 01:49:55 EDT
publican-2.2-0.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc13
Comment 7 Fedora Update System 2010-10-06 01:51:09 EDT
publican-2.2-0.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc12
Comment 8 Fedora Update System 2010-10-06 01:51:10 EDT
publican-2.2-0.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc14
Comment 9 Fedora Update System 2010-10-08 16:41:16 EDT
publican-2.2-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Noriko Mizumoto 2012-02-21 00:20:02 EST
This problem has been reported with Bug 784132 again.
RHEV Admin GD and RHEV REST API GD are also affected.
Comment 11 Manuel Ospina 2012-02-21 00:47:11 EST
trying to reopen this bug as the problem is still present in Japanese (see Comment 10)
Comment 12 Noriko Mizumoto 2012-02-21 00:48:58 EST
*** Bug 784132 has been marked as a duplicate of this bug. ***
Comment 13 Eric Towns 2012-04-09 09:22:05 EDT
*** Bug 810769 has been marked as a duplicate of this bug. ***
Comment 14 Noriko Mizumoto 2012-04-16 00:06:47 EDT
Ping, can you pls give some update?

RHEV REST API Guide's pdf on docs.rh.com still does not render correctly. 

1. download pdf from http://docs.redhat.com/docs/ja-JP/Red_Hat_Enterprise_Virtualization/3.0/html/REST_API_Guide/
2. check the page 7 of 180
3. Japanese translations inside the tags <citetitle> do not render correctly.

4. build pdf locally with publican-2.8-2.el6eng.x86_64
5. it does render correctly
Comment 17 Yuko Katabami 2012-05-31 00:31:07 EDT
Just to update the current state upon Manuel's request:

Rudi still had some issues with rebuilding.
Publican itself has been fixed, but rebuild has not been completed due to some problems.

In terms of Yuki's request for RHEL 6 documentation listed at https://access.redhat.com/knowledge/docs/Red_Hat_Enterprise_Linux/?locale=ja-JP,  RHEL 6.2 Release Notes is the only one left unsolved.
When Rudi tried to rebuild it using the existing codes from the last package, it failed, so he tried to re-brew, but it contained untranslated English string (because Czech writers updated the en-US files in the repository after published)
Ticket for this mass build effort is: https://engineering.redhat.com/rt/Ticket/Display.html?id=145666
Comment 18 Yuko Katabami 2012-05-31 00:34:21 EDT
Just to update the current state upon Manuel's request:

Rudi still had some issues with rebuilding.
Publican itself has been fixed, but rebuild has not been completed due to some problems.

In terms of Yuki's request for RHEL 6 documentation listed at https://access.redhat.com/knowledge/docs/Red_Hat_Enterprise_Linux/?locale=ja-JP,  RHEL 6.2 Release Notes is the only one left unsolved.
When Rudi tried to rebuild it using the existing codes from the last package, it failed, so he tried to re-brew, but it contained untranslated English string (because Czech writers updated the en-US files in the repository after published)
Ticket for this mass build effort is: https://engineering.redhat.com/rt/Ticket/Display.html?id=145666
Comment 19 Jeff Fearn 2013-01-23 05:28:26 EST
Is this still an issue?
Comment 21 Ruediger Landmann 2013-07-29 19:50:04 EDT
*** Bug 745370 has been marked as a duplicate of this bug. ***