Bug 630316

Summary: [evol][ml_IN] Translation mismatch with Text and button on Setup Screen and other update required
Product: Red Hat Enterprise Linux 6 Reporter: A S Alam <aalam>
Component: evolutionAssignee: Matthew Barnes <mbarnes>
Status: CLOSED ERRATA QA Contact: QE Internationalization Bugs <qe-i18n-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: 6.1CC: apeter, eng-l10n-bugs, jkoten, mcrha, mshao, smaitra
Target Milestone: rcKeywords: Translation
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: evolution-2.28.3-15.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 700791 (view as bug list) Environment:
Last Closed: 2011-05-19 10:08:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 700791    
Attachments:
Description Flags
Last Screen of Evolution Setup
none
ZWJ or ZWNJ issue
none
ZWJ or ZWNJ issue
none
The Newer version's Last Screen of evolution. Need to confirm from LM, if this is OK.
none
The ZWJ or ZWNJ issue in IMAP page in the new Evolution Set up page. LM, Please confirm
none
The ZWJ or ZWNJ issue in SMTP page in the new Evolution Set up page. LM, Please confirm none

Description A S Alam 2010-09-04 14:50:17 EDT
Created attachment 443090 [details]
Last Screen of Evolution Setup

Description of problem:
Evolution Setup seems problem at Setup screen, at last Window of Evolution Setup, translation of "Finish" in Label (which says to press "Finish" button), and Translation of "Finsih" Button seems different.

Version-Release number of selected component (if applicable):
evolution-2.28.3-10.el6.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. run setup, go to last window
2. check yellow underline text in first Screenshot
3. Compare Both Label's 'Finish' and actual 'Finish'
4. Please check other Screenshot with Yellow line, which showing ZWJ or ZWNJ in translation
  
Actual results:
Label and Button text is different

Expected results:
should be same and ZWJ/ZWNJ should not be visiable

Additional info:
Yellow mark showing problem
Comment 1 A S Alam 2010-09-04 14:51:00 EDT
Created attachment 443091 [details]
ZWJ or ZWNJ issue
Comment 2 A S Alam 2010-09-04 14:51:36 EDT
Created attachment 443092 [details]
ZWJ or ZWNJ issue
Comment 4 Matthew Barnes 2010-11-29 22:48:37 EST
I assume the localization team will provide a patch for this?  Conditional NAK.
Comment 5 Ani Peter 2010-12-07 07:51:45 EST
Have updated all translations in all branches including 2.28 and downstream.
Gnome 2.28 at: http://l10n.gnome.org/module/evolution/#gnome-2-28

Please let me know if anything else to be done.
Thanks!
Comment 6 Ankit Patel 2010-12-07 08:23:35 EST
A patch submitted via attachment #465234 [details] in the bug #630314 should fix this issue as well.

Thanks!
Ankit
Comment 7 Milan Crha 2010-12-08 03:02:20 EST
Committed to sources, will be part of evolution-2.28.3-11.el6
Comment 10 Milan Crha 2011-01-17 12:09:47 EST
There were done some builds last week with this included, the latest is
evolution-2.28.3-15.el6
thus I'm moving this to Modified.
Comment 11 A S Alam 2011-01-17 23:52:59 EST
i18n QE group (qe-i18n-bugs@redhat.com) will like test this build. ack+
Comment 14 Satyabrata Maitra 2011-04-28 07:19:40 EDT
Tested this bug. Still, I need confirmation from Language maintainer of Malayalam locale to verify it once, before we proceed with it.

I need to make a NEED_INFO to apeter@redhat.com to confirm, although I tested
and it seems some errors has been fixed, but not 100%.

Tested with the version of the Component :

evolution-debuginfo-2.28.3-24.el6    
evolution-2.28.3-24.el6   
evolution-help-2.28.3-24.el6

RHEL6.1 Distro.

Screen shots attached.
Comment 15 Satyabrata Maitra 2011-04-28 07:20:50 EDT
Created attachment 495504 [details]
The Newer version's Last Screen of evolution. Need to confirm from LM, if this is OK.
Comment 16 Satyabrata Maitra 2011-04-28 07:22:05 EDT
Created attachment 495505 [details]
The ZWJ or ZWNJ issue in IMAP page in the new Evolution Set up page. LM, Please confirm
Comment 17 Satyabrata Maitra 2011-04-28 07:22:49 EDT
Created attachment 495506 [details]
The ZWJ or ZWNJ issue in SMTP page in the new Evolution Set up page. LM, Please confirm
Comment 18 Satyabrata Maitra 2011-04-28 07:24:47 EDT
Hi Ani

I have tested for this bug. I need some confirmation from your side, if my
observation is correct. Please see if the ZWJ or ZWNJ issue those were present in the older version, is eliminated or corrected in the newer version or not.

I have attached some screen shots above with proper description. Please confirm
me whether these are correct of not.

FYI : the screen shots of the older packages with error, is also attached with
this bug, by aalam. You can see those as well, to compare and know what has
been fixed in the new version.

Component version where the errors are suppose to be corrected is :

evolution-2.28.3-24.el6 
evolution-debuginfo-2.28.3-24.el6      
evolution-help-2.28.3-24.el6

Please inform me asap. We need to proceed with an errata.
Comment 19 Ani Peter 2011-04-28 07:40:52 EDT
(In reply to comment #15)
> Created attachment 495504 [details]
> The Newer version's Last Screen of evolution. Need to confirm from LM, if this
> is OK.

Satya, this attachement looks good. Thanks!
Comment 20 Ani Peter 2011-04-29 03:25:40 EDT
(In reply to comment #17)
> Created attachment 495506 [details]
> The ZWJ or ZWNJ issue in SMTP page in the new Evolution Set up page. LM, Please
> confirm

This is not ZWJ/ZWNJ issue and the issue is reported on Bug 630314. Hence shall comment about this on Bug 630314. Doing this as per QE's advise.
Thanks!
Comment 21 Ani Peter 2011-04-29 03:40:58 EDT
(In reply to comment #16)
> Created attachment 495505 [details]
> The ZWJ or ZWNJ issue in IMAP page in the new Evolution Set up page. LM, Please
> confirm

Yes this is a ZWNJ issue in the word "Password" and comes from evolution-data-server. Hence, am afraid this is not part of this bug. I will be correcting the string and updating the file evolution-data-server. Thanks!
Comment 25 errata-xmlrpc 2011-05-19 10:08:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0714.html