Bug 630632

Summary: split ghostscript libs out to a subpackage
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: ghostscriptAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: mclasen, rdieter, redhat-bugzilla, twaugh
Target Milestone: ---Keywords: FutureFeature, Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: ghostscript-9.00-12.fc15 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-09-18 16:02:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 842351    
Bug Blocks: 462851, 661442    

Description Peter Robinson 2010-09-06 13:06:17 UTC
evince pulls in all of ghostscript by the use of libspectre which uses libgs.so

Would it be possible to split libgs out into a ghostscript-libs sub package? I'm not sure how much of the 20 Mb of other files in the main ghostscript package are needed by libgs.so but there are a lot of utilities etc that won't be.

This would be very useful for mobile devices with small amounts of storage available such as the XO-1 and various tablet/mid arm related devices that are now available.

Comment 1 Tim Waugh 2011-01-28 15:49:26 UTC
I think that the majority of the package will be needed by libso.so.  As you said, not the utilities in /usr/bin... but they come to 33kb.

The bigger win would be to find a way to share data with poppler-data.

Comment 2 Tim Waugh 2011-01-28 17:21:25 UTC
Try ghostscript-9.00-12.fc15, which requires poppler-data and adds its directories to the resource search path.  If poppler-data is already pulled in by something else, this should save about 11Mb.

Comment 3 Rex Dieter 2012-09-15 21:37:10 UTC
In fixing bug #842351 , the test case provided there fails as ghostscript (still) seems not to use /usr/share/poppler/cMap , re-opening.

Not sure if it ever worked, or of the problem I'm seeing is some sort of regression in ghostscript-9.05-4.fc17

Comment 4 Rex Dieter 2012-09-18 16:02:37 UTC
Tim and I discussed this on irc, and agreed poppler-data will provide symlinks to ghostscript somehow.  I'll go ahead reclose this, and track moving forward in bug #842351

Comment 5 Caolan McNamara 2017-07-10 10:17:56 UTC
*** Bug 466512 has been marked as a duplicate of this bug. ***