Bug 466512 - can we share cmaps with ghostscript ?
Summary: can we share cmaps with ghostscript ?
Keywords:
Status: CLOSED DUPLICATE of bug 630632
Alias: None
Product: Fedora
Classification: Fedora
Component: poppler
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 466513 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-10 17:09 UTC by Matthias Clasen
Modified: 2017-07-10 10:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-10 10:17:56 UTC
Type: ---


Attachments (Terms of Use)

Description Matthias Clasen 2008-10-10 17:09:01 UTC
It appears that 

/usr/share/poppler/cMap and
/usr/share/ghostscript/8.63/Resource/CMap/

are two pretty much identical trees of files weighing >11M each.

Any way to share the two ? Think of the children !

Comment 1 Rex Dieter 2008-10-10 17:50:48 UTC
*** Bug 466513 has been marked as a duplicate of this bug. ***

Comment 2 Bug Zapper 2008-11-26 03:45:11 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Rex Dieter 2009-07-30 12:49:11 UTC
Tim, have you got any notions or ideas on how best to share poppler-data (see bug #507675 ) with ghostscript?  2 quick ideas come to mind:
1.  patch ghostscript to use poppler-data directly, including location and layout
2.  use symlinks to make poppler-data layout the data on-disk as ghostscript uses it now.
3.  use some hybrid of 1 and 2

Personally, I'd prefer 1, which would likely be the most upstreamable approach (to me).  What say you?

Comment 5 Rex Dieter 2010-01-19 17:59:34 UTC
Tim, ping ?

Comment 6 Tim Waugh 2010-02-02 16:18:10 UTC
I still haven't had the time to look at this, and don't really know how the internals of the CMap code work in ghostscript. :-(

Comment 7 Tim Waugh 2011-02-14 12:07:13 UTC
Please take a look at ghostscript in current rawhide...

Comment 8 Jindrich Novy 2011-09-25 18:41:28 UTC
FYI: TeX Live now prefers /usr/share/poppler/cMap over the ghostscript directory. In any case it would be nice to see it unified.

Comment 9 Tim Waugh 2011-09-26 09:53:58 UTC
Please see comment #7, which refers to ghostscript-9.00-12.

Comment 10 Fedora Admin XMLRPC Client 2016-10-14 08:07:05 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 11 Caolan McNamara 2017-07-10 10:17:56 UTC
Turns out that comment #9 is tersely suggesting that this is fixed in ghostscript with bug#630632

*** This bug has been marked as a duplicate of bug 630632 ***


Note You need to log in before you can comment on or make changes to this bug.