Bug 634182

Summary: libcanberra-gtk2 Requires libcanberra-gtk3 ?
Product: [Fedora] Fedora Reporter: Rex Dieter <rdieter>
Component: libcanberraAssignee: Lennart Poettering <lpoetter>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: awilliam, kevin, lpoetter, mclasen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-01 17:45:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 633298    

Description Rex Dieter 2010-09-15 12:51:50 UTC
libcanberra-gtk2's
Requires: libcanberra-gtk3

is pulling gtk3 and gtk3-immodule-xim onto the kde spin , making it harder to fit < 700mb .  (At least until bug #605675 is addressed, so metacity and libcanberra-gtk2 isn't pulled in by firstboot)

Not sure of the motivations for adding this dependency, but can alternatives be considered?

Comment 1 Kevin Kofler 2010-09-15 13:05:28 UTC
The specfile says:
# GConf and other stuff is included in the gtk3 package, so always pull that in.

Please move the shared stuff to the -gtk2 subpackage on F14, given that the GNOME 3 feature has been reverted.

Comment 2 Rex Dieter 2010-10-01 17:38:18 UTC
removing F14Blocker-kde , since bug #605675 got fixed in the meantime (woo)

Comment 3 Adam Williamson 2010-10-01 17:45:01 UTC
AFAICT current libcanberra-gtk2 package, libcanberra-gtk2-0.25-4.fc14.x86_64 , does not pull in any GTK+3 deps, so this is fixed.