Bug 605675 - firstboot -> metacity dep
firstboot -> metacity dep
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On:
Blocks: F14Target-kde F14Beta-accepted/F14BetaFreezeExcept 643416
  Show dependency treegraph
 
Reported: 2010-06-18 10:31 EDT by Rex Dieter
Modified: 2011-04-14 13:01 EDT (History)
5 users (show)

See Also:
Fixed In Version: firstboot-1.113-3.fc14
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 00:08:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
add support for kwin (641 bytes, patch)
2010-09-15 15:22 EDT, Rex Dieter
no flags Details | Diff

  None (edit)
Description Rex Dieter 2010-06-18 10:31:35 EDT
Mostly for tracking purposes, but the hope is to someday not having to ship metacity on the kde spin.

Means, working on an implementation to make this window-manager agnostic.
Comment 1 Kevin Kofler 2010-09-15 08:59:00 EDT
Note that Metacity is now also dragged in by Anaconda itself, used by the installer environment. It's not really needed by liveinst, but dragged in as a dependency anyway. So there are now 2 things dragging in Metacity, both problems should be solved.
Comment 2 Rex Dieter 2010-09-15 09:13:07 EDT
Any hints on how to implement this?

I naively changed the call /usr/bin/metacity to /usr/bin/kwin , and all I get is a hung/black screen. :(
Comment 3 Rex Dieter 2010-09-15 09:37:55 EDT
OK, I tried a couple more times, and it seems to work ok.  Will do more testing.
Comment 4 Rex Dieter 2010-09-15 10:48:14 EDT
Alrighty, here's a quick-n-dirty patch to xfrontend.py to make something like this work,

$ diff -u xfrontend.py.kwin xfrontend.py
--- xfrontend.py.kwin   2010-08-30 05:57:44.000000000 -0500
+++ xfrontend.py        2010-09-15 09:50:34.719023820 -0500
@@ -42,7 +42,11 @@
         self._wm_pid = os.fork()
 
         if not self._wm_pid:
-            path = "/usr/bin/metacity"
+            paths = ["/usr/bin/metacity", "/usr/bin/kwin"]
+            for path in paths:
+            if os.access(path, os.X_OK): 
+                 break 
+
             args = [path, "--display", os.environ["DISPLAY"]]
             os.execvp(path, args)


Then swap out
Requires: metacity

with something like
Requires: system(wm)

and have both metacity and kdebase-workspace (owner of kwin), include:
Provides: system(wm)
Comment 5 Adam Williamson 2010-09-15 12:45:10 EDT
propose for F14 Beta NTH list (new system for tracking bugs that aren't
blockers but for which we'll accept fixes through the freeze)
Comment 6 Rex Dieter 2010-09-15 15:22:53 EDT
Created attachment 447553 [details]
add support for kwin

The previous inline patch had the spacing botched, here's something that actually works.
Comment 7 Rex Dieter 2010-09-15 15:33:04 EDT
resetting owner
Comment 8 Fedora Update System 2010-09-15 16:22:54 EDT
firstboot-1.113-3.fc14,metacity-2.30.0-8.fc14,kdebase-workspace-4.5.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/firstboot-1.113-3.fc14,metacity-2.30.0-8.fc14,kdebase-workspace-4.5.1-3.fc14
Comment 9 Fedora Update System 2010-09-15 23:29:04 EDT
firstboot-1.113-3.fc14, metacity-2.30.0-8.fc14, kdebase-workspace-4.5.1-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update firstboot metacity kdebase-workspace'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/firstboot-1.113-3.fc14,metacity-2.30.0-8.fc14,kdebase-workspace-4.5.1-3.fc14
Comment 10 Christoph Wickert 2010-09-19 07:29:24 EDT
I wonder why this was not discussed on fedora-devel or the spins mailing list. If Adam didn't tell me, I would have missed it. I'm sure other spins are affected as well.

(In reply to comment #4)
> Alrighty, here's a quick-n-dirty patch to xfrontend.py to make something like
> this work,
> 
> $ diff -u xfrontend.py.kwin xfrontend.py
> --- xfrontend.py.kwin   2010-08-30 05:57:44.000000000 -0500
> +++ xfrontend.py        2010-09-15 09:50:34.719023820 -0500
> @@ -42,7 +42,11 @@
>          self._wm_pid = os.fork()
> 
>          if not self._wm_pid:
> -            path = "/usr/bin/metacity"
> +            paths = ["/usr/bin/metacity", "/usr/bin/kwin"]

We also need this for /usr/bin/xfwm4 (Xfce) and /usr/bin/openbox (LXDE). I have built the necessary packages already:
https://admin.fedoraproject.org/updates/xfwm4-4.6.2-2.fc14
https://admin.fedoraproject.org/updates/openbox-3.4.11.2-4.fc14
Comment 11 Kevin Kofler 2010-09-19 09:46:48 EDT
Added: http://koji.fedoraproject.org/koji/taskinfo?taskID=2475796
Please test.
Comment 13 Fedora Update System 2010-09-22 00:08:43 EDT
firstboot-1.113-3.fc14, metacity-2.30.0-8.fc14, kdebase-workspace-4.5.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Peter Robinson 2011-04-14 10:04:19 EDT
Having found this bug because I discovered the SoaS spin, which uses metacity as its WM, we're somehow pulling openbox. It seems there's two different types of Provides: and I'm wondering if one or the other is correct and that's why I'm getting open box as well. Not sure what the "= kwin" and "= metacity" does. I've only ever seen = used to provide specific version numbers.

grep firstboot *
xfwm4.spec:- Provide firstboot(windowmanager)
openbox.spec:Provides:	firstboot(windowmanager)
openbox.spec:- Provide firstboot(windowmanager)
kdebase-workspace.spec:Provides: firstboot(windowmanager) = kwin
kdebase-workspace.spec:- Provides: firstboot(windowmanager)  (#605675)
metacity.spec:Provides: firstboot(windowmanager) = metacity
metacity.spec:- firstboot -> metacity dep (#605675)
Comment 15 Kevin Kofler 2011-04-14 12:02:12 EDT
One bug here is that openbox Provides: firstboot(windowmanager), but doesn't actually implement the correct command-line arguments for firstboot.

We fixed that in F14 by removing the Provides again:
https://admin.fedoraproject.org/updates/openbox-3.4.11.2-5.fc14
but it looks like the offending Provides is still there in F15 and Rawhide.

(There may have been the expectation that the required command-line arguments would be implemented for F15, but they weren't.)


Another issue is that it looks like yum is, for some reason, dragging in openbox even though metacity is already on the spin. I'm not sure why that is. Listing metacity in the kickstart explicitly might help.
Comment 16 Peter Robinson 2011-04-14 12:23:37 EDT
(In reply to comment #15)
> One bug here is that openbox Provides: firstboot(windowmanager), but doesn't
> actually implement the correct command-line arguments for firstboot.
> 
> We fixed that in F14 by removing the Provides again:
> https://admin.fedoraproject.org/updates/openbox-3.4.11.2-5.fc14
> but it looks like the offending Provides is still there in F15 and Rawhide.
> 
> (There may have been the expectation that the required command-line arguments
> would be implemented for F15, but they weren't.)

Any chance we could get a fix one way or the other for F-15

> Another issue is that it looks like yum is, for some reason, dragging in
> openbox even though metacity is already on the spin. I'm not sure why that is.
> Listing metacity in the kickstart explicitly might help.

I can only presume its due to the fact that openbox has the shortest name. I'll test explicitly adding metacity this evening.

Note You need to log in before you can comment on or make changes to this bug.