Bug 642951

Summary: DVD upgrading requires cd install media
Product: [Fedora] Fedora Reporter: He Rui <rhe>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: anaconda-maint-list, jonathan, notting, robatino, vanmeeuwen+fedora
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-25 18:44:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
The screen when upgrading with DVD
none
Logs under /tmp
none
Repomd.xml differences between F14 beta and Final-TC1 none

Description He Rui 2010-10-14 09:49:38 UTC
Created attachment 453424 [details]
The screen when upgrading with DVD

Version-Release number of selected component (if applicable):
Anaconda 14.19
F14-Final-TC1

How reproducible:
100%

Steps to Reproduce:
0. Prepared a F-13 minimal installed system in KVM.
1. Boot F14-Final-TC1-disc1.iso on the system.
2. Choose 'upgrade system' and select 'Create new bootloader configuration'. Click 'Next'
3. You'll see a screen popped up saying: The software you have selected for install require the following discs: #1, #2.
4. Click 'Reboot' and shut down the guest
5. Change the cdrom to point to F14-Final-TC1-DVD.iso instead of disc1.
6. Boot DVD and executed step 2 again.
7. The same screen displayed as step3.    

Expected results:
CD install media requirement window shouldn't pop up during DVD upgrade. 

Additional info:
If at step5 and6, I boot F14-beta instead, this issue won't happen.

Comment 1 He Rui 2010-10-14 09:53:18 UTC
Created attachment 453426 [details]
Logs under /tmp

Don't know if it's related, a slightly different steps can cause an exception, see bug#642913.

Comment 2 Chris Lumens 2010-10-14 19:19:07 UTC
Has something changed in the repo metadata between the beta and now?  On the DVD, everything should just be marked as being in #1.  We certainly haven't done anything to this reporting code in anaconda for a while now.

Comment 3 He Rui 2010-10-15 06:58:21 UTC
Created attachment 453655 [details]
Repomd.xml differences between F14 beta and Final-TC1

Comment 4 Bill Nottingham 2010-10-15 14:11:44 UTC
I don't know of anything that's changed here.

Comment 5 Bill Nottingham 2010-10-15 14:15:54 UTC
He Rui - have you confirmed while in the installer that it is reading the TC1 DVD correctly?

Comment 6 Bill Nottingham 2010-10-15 14:31:13 UTC
I looked at the TC1 x86_64 DVD. All the 'location' tags in primary point to:

xml:base="media://1286926503.224937"

which is the same as what's in repomd.xml. It almost sounds like qemu didn't reattach the DVD correctly.

Comment 7 Bill Nottingham 2010-10-15 14:38:12 UTC
In fact, we already have reports of qemu not handling this correctly in bugzilla, I'm marking this as a duplicate of bug 623126. Please reopen if you can reproduce this on bare metal.

*** This bug has been marked as a duplicate of bug 623126 ***

Comment 8 He Rui 2010-10-18 08:11:08 UTC
(In reply to comment #7)
> In fact, we already have reports of qemu not handling this correctly in
> bugzilla, I'm marking this as a duplicate of bug 623126. Please reopen if you
> can reproduce this on bare metal.
> 
> *** This bug has been marked as a duplicate of bug 623126 ***

I can reproduce it on bare metal too, also in kvm, it's obvious that the guest has recognized the DVD media changed in step 5 as DVD can be successfully mounted on /mnt/source with the size about 3.3G. 

Tell me if you need more info to debug this issue.

Comment 9 Chris Lumens 2010-10-25 18:44:35 UTC
For F15, we are moving to a single disc install media, so this will no longer be an issue.