Bug 642951 - DVD upgrading requires cd install media
DVD upgrading requires cd install media
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-14 05:49 EDT by He Rui
Modified: 2010-10-25 14:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-25 14:44:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The screen when upgrading with DVD (51.78 KB, image/png)
2010-10-14 05:49 EDT, He Rui
no flags Details
Logs under /tmp (30.37 KB, application/x-gzip)
2010-10-14 05:53 EDT, He Rui
no flags Details
Repomd.xml differences between F14 beta and Final-TC1 (7.76 KB, patch)
2010-10-15 02:58 EDT, He Rui
no flags Details | Diff

  None (edit)
Description He Rui 2010-10-14 05:49:38 EDT
Created attachment 453424 [details]
The screen when upgrading with DVD

Version-Release number of selected component (if applicable):
Anaconda 14.19
F14-Final-TC1

How reproducible:
100%

Steps to Reproduce:
0. Prepared a F-13 minimal installed system in KVM.
1. Boot F14-Final-TC1-disc1.iso on the system.
2. Choose 'upgrade system' and select 'Create new bootloader configuration'. Click 'Next'
3. You'll see a screen popped up saying: The software you have selected for install require the following discs: #1, #2.
4. Click 'Reboot' and shut down the guest
5. Change the cdrom to point to F14-Final-TC1-DVD.iso instead of disc1.
6. Boot DVD and executed step 2 again.
7. The same screen displayed as step3.    

Expected results:
CD install media requirement window shouldn't pop up during DVD upgrade. 

Additional info:
If at step5 and6, I boot F14-beta instead, this issue won't happen.
Comment 1 He Rui 2010-10-14 05:53:18 EDT
Created attachment 453426 [details]
Logs under /tmp

Don't know if it's related, a slightly different steps can cause an exception, see bug#642913.
Comment 2 Chris Lumens 2010-10-14 15:19:07 EDT
Has something changed in the repo metadata between the beta and now?  On the DVD, everything should just be marked as being in #1.  We certainly haven't done anything to this reporting code in anaconda for a while now.
Comment 3 He Rui 2010-10-15 02:58:21 EDT
Created attachment 453655 [details]
Repomd.xml differences between F14 beta and Final-TC1
Comment 4 Bill Nottingham 2010-10-15 10:11:44 EDT
I don't know of anything that's changed here.
Comment 5 Bill Nottingham 2010-10-15 10:15:54 EDT
He Rui - have you confirmed while in the installer that it is reading the TC1 DVD correctly?
Comment 6 Bill Nottingham 2010-10-15 10:31:13 EDT
I looked at the TC1 x86_64 DVD. All the 'location' tags in primary point to:

xml:base="media://1286926503.224937"

which is the same as what's in repomd.xml. It almost sounds like qemu didn't reattach the DVD correctly.
Comment 7 Bill Nottingham 2010-10-15 10:38:12 EDT
In fact, we already have reports of qemu not handling this correctly in bugzilla, I'm marking this as a duplicate of bug 623126. Please reopen if you can reproduce this on bare metal.

*** This bug has been marked as a duplicate of bug 623126 ***
Comment 8 He Rui 2010-10-18 04:11:08 EDT
(In reply to comment #7)
> In fact, we already have reports of qemu not handling this correctly in
> bugzilla, I'm marking this as a duplicate of bug 623126. Please reopen if you
> can reproduce this on bare metal.
> 
> *** This bug has been marked as a duplicate of bug 623126 ***

I can reproduce it on bare metal too, also in kvm, it's obvious that the guest has recognized the DVD media changed in step 5 as DVD can be successfully mounted on /mnt/source with the size about 3.3G. 

Tell me if you need more info to debug this issue.
Comment 9 Chris Lumens 2010-10-25 14:44:35 EDT
For F15, we are moving to a single disc install media, so this will no longer be an issue.

Note You need to log in before you can comment on or make changes to this bug.