Bug 646843

Summary: images/install.img will no longer exist in F-15 and newer
Product: [Fedora] Fedora Reporter: James Laska <jlaska>
Component: preupgradeAssignee: Richard Hughes <rhughes>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: alejandro_liu, awilliam, fedora, jturner, rhe, rhughes, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: preupgrade-1.1.9-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-11 11:16:06 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 657618    
Attachments:
Description Flags
lazy-fix.patch
none
less-lazy-fix.patch
none
preupgrade-cli.patch none

Description James Laska 2010-10-26 08:49:53 EDT
The stage#2 install.img is going away for good.  The image will no longer be available as of F-15 and newer.  Preupgrade will need to be adjusted accordingly.  I'll be happy to fiddle with some patches once F-15 test images are available.

I have some concerns on how best to handle the situation of limited disk space in /boot since the initrd.img now contains *both* loader and stage2.

For discussions on this feature see https://www.redhat.com/archives/anaconda-devel-list/2010-August/msg00020.html
Comment 1 Richard Hughes 2011-01-21 09:12:55 EST
Sure, it kinda complicates the small /boot case, although I'm not overly bothered with just saying to the user "sorry, you can't do that" given we've defaulted to lvm and a larger boot for some time now.

Ping me when there's a test compose tree and I'll see what breaks. Thanks.
Comment 2 James Laska 2011-02-10 14:59:54 EST
Adding to F15Beta so we don't forget that this impacts the F15Beta release criteria (https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria).

Test composes are coming online now and are available from http://serverbeach1.fedoraproject.org/pub/alt/stage/
Comment 3 James Laska 2011-03-02 13:03:42 EST
Created attachment 481921 [details]
lazy-fix.patch

A quick'n'dirty lazy patch to address this problem.
Comment 4 James Laska 2011-03-02 13:04:45 EST
Created attachment 481922 [details]
less-lazy-fix.patch

A slightly less lazy fix.  I've tested both fixes and they work ... but I'm sure there is a more appropriate and preferred way to add support.  Note, these patches only fix preupgrade-gtk.py.
Comment 5 Richard Hughes 2011-03-03 05:01:08 EST
(In reply to comment #4)
> Created attachment 481922 [details]
> less-lazy-fix.patch

I've applied this after removing the added error message. There's nothing the user can do about a missing stage2 in F15+, so we don't need to tell them anything.

Thanks,

Richard.
Comment 6 James Laska 2011-03-07 09:32:05 EST
(In reply to comment #5)
> (In reply to comment #4)
> > Created attachment 481922 [details]
> > less-lazy-fix.patch
> 
> I've applied this after removing the added error message. There's nothing the
> user can do about a missing stage2 in F15+, so we don't need to tell them
> anything.

Do you need me to also patch the preupgrade-cli.py version?  If you can point me to the patch accepted, I'll be happy to provide a -cli version.
Comment 7 Richard Hughes 2011-03-09 04:48:07 EST
That would be most appreciated, thanks.
Comment 8 Adam Williamson 2011-03-11 13:41:02 EST
Discussed at 2011-03-11 blocker review meeting. This is a clear blocker under criterion "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation of the previous stable Fedora release, either via preupgrade or by booting to the installer manually".
Comment 9 James Laska 2011-03-14 09:42:18 EDT
Created attachment 484187 [details]
preupgrade-cli.patch

(In reply to comment #7)
> That would be most appreciated, thanks.

Tested patch.  Note, this patch also removes data/releases.txt from the git repository.  I suspect a corresponding preupgrade.spec change will be needed if this portion of the patch is accepted?
Comment 10 Richard Hughes 2011-03-15 06:46:26 EDT
Committed, thanks:

commit 176a61246384533897879bd1aa961afdf5425de9
Author: James Laska <jlaska@redhat.com>
Date:   Tue Mar 15 10:38:32 2011 +0000

    Fix preupgrade-cli now stage2 is not shipped in F15
    
    Signed-off-by: Richard Hughes <richard@hughsie.com>
Comment 11 James Laska 2011-03-16 14:54:36 EDT
Fixed in preupgrade-1.1.9-1.  Pending test feedback from preupgrade test day, this issue will move to ON_QA and be included an a future bodhi update.

http://koji.fedoraproject.org/koji/packageinfo?packageID=6045
Comment 12 Adam Williamson 2011-03-25 13:48:02 EDT
Discussed at the 2011-03-25 blocker review meeting. We note that we had the Test Day and it seems to have been 'successful' as far as this issue is concerned. Can the updated preupgrade be submitted as an update now?
Comment 13 He Rui 2011-03-31 05:18:15 EDT
So far we are testing upgrading to F15 beta, please submit preupgrade-1.1.9-1 in comment#11 as an update asap.
Comment 15 He Rui 2011-04-07 01:02:58 EDT
Verified the updates worked as expected. Thanks, James.
Comment 16 James Laska 2011-04-07 07:53:21 EDT
(In reply to comment #15)
> Verified the updates worked as expected. Thanks, James.

Nice work, thanks Hurry and Richard!
Comment 17 Adam Williamson 2011-04-11 11:16:06 EDT
the update's gone stable in the two releases where it's critical atm, it'll go stable in f15 when freeze is listed: closing.