This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 648855

Summary: Virsh help / man page typo
Product: [Fedora] Fedora Reporter: zhanghaiyan <yoyzhang>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 14CC: berrange, clalance, crobinso, eblake, itamar, jforbes, jyang, veillard, virt-maint, weizhan, yimwang
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-03 19:06:36 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description zhanghaiyan 2010-11-02 06:13:01 EDT
Description of problem:
I find several virsh help or man page tiny typo, so use this bug to track this kind of issues.

Version-Release number of selected component (if applicable):
libvirt-0.8.4-3.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1. man page line 447
2. man page line 307
3.
  
Actual results:
1. domain-id can be specified as an short integer
2. edit domain.xml

Expected results:
1. Change 'an' to 'a'
2. virsh edit domain.xml

Additional info:
Comment 1 Osier Yang 2010-11-02 06:27:09 EDT
fixed, upstream patch:

https://www.redhat.com/archives/libvir-list/2010-November/msg00101.html
Comment 2 weizhang 2010-11-02 06:53:42 EDT
on man page of virsh for command migrate it loses optional parameters and description such as --p2p --direct --tunnelled --persistent --undefinesource --copy-storage-inc --copy-storage-all

for command attach-disk, it loses the optional parameters and description --sourcetype
Comment 5 wangyimiao 2010-11-19 03:03:18 EST
1.# virsh help reboot
.........................
  DESCRIPTION
    Run a reboot command in the target domain.
..........................

Description incorrect. Expected:"Run reboot command in host to reboot
target domain"
Comment 6 Fedora Admin XMLRPC Client 2011-09-22 13:59:03 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-09-22 14:02:51 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2011-11-30 14:59:06 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2011-11-30 15:00:10 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Fedora Admin XMLRPC Client 2011-11-30 15:05:14 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Fedora Admin XMLRPC Client 2011-11-30 15:05:33 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Eric Blake 2011-12-03 19:06:36 EST
(In reply to comment #0)
> Description of problem:
> I find several virsh help or man page tiny typo, so use this bug to track this
> kind of issues.

The initial complaint of typos has been fixed.  New issues should be reported on libvir-list@redhat.com or filed as new BZs.

(In reply to comment #5)
> 1.# virsh help reboot
> .........................
>   DESCRIPTION
>     Run a reboot command in the target domain.

This has nothing to do with typos; while I agree that this wording could be improved, it should be brought up on the list rather than extending the life of this bug.  Besides,

> ..........................
> 
> Description incorrect. Expected:"Run reboot command in host to reboot
> target domain"

I'm not sure I like this suggested wording any better.  The host really does request that the guest reboot itself (either via an ACPI interrupt or via a guest agent command); the host can't do the reboot itself, since reboot requires guest cooperation.

Maybe it would be better as:
'request that the target domain be rebooted (requires guest cooperation)'
but again, bring that up on list.
Comment 13 Eric Blake 2011-12-03 19:10:03 EST
Marking as closed nextrelease; it's not worth backporting spelling fixes into F14 at this time, but newer versions should have fewer typos.  I'm also doing another sweep of 'an' misuses, via https://www.redhat.com/archives/libvir-list/2011-December/msg00176.html