Bug 650675

Summary: [abrt] abrt-1.1.13-2.fc14: yyresolveStates: Process /usr/bin/abrt-backtrace was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Leandro Costa Silva <leandro>
Component: abrtAssignee: Jiri Moskovcak <jmoskovc>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: anton, dfediuck, dvlasenk, dwayne, fedora, gabicr, iprikryl, jmoskovc, kklic, maamoun4188, mtoman, npajkovs, redhat, theophanis_kontogiannis
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:94113bb66c84af85e1a38b5d1bfaa0b9b7b21d4e
Fixed In Version: abrt-2.0.1-2.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-26 16:18:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: backtrace none

Description Leandro Costa Silva 2010-11-07 18:21:14 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: abrt-backtrace --single-thread --remove-exit-handlers --frame-depth=5 --remove-noncrash-frames /var/spool/abrt/ccpp-1289140664-2213/backtrace
component: abrt
crash_function: yyresolveStates
executable: /usr/bin/abrt-backtrace
kernel: 2.6.35.6-48.fc14.x86_64
package: abrt-1.1.13-2.fc14
rating: 4
reason: Process /usr/bin/abrt-backtrace was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1289153912
uid: 500

Comment 1 Leandro Costa Silva 2010-11-07 18:21:21 UTC
Created attachment 458486 [details]
File: backtrace

Comment 2 Erwan Legrand 2010-11-08 14:25:51 UTC
Package: abrt-1.1.13-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Backtrace generation hangs.
2. Close the "generating backtrace" window

Comment 3 Dwayne Bailey 2010-11-12 06:08:27 UTC
Package: abrt-1.1.13-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


Comment
-----
Cancelled a backtrace generation that was taking an awefully long time.

Comment 4 Theophanis Kontogiannis 2010-11-17 12:11:24 UTC
Package: abrt-1.1.13-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


Comment
-----
Reported a bug

Comment 5 Jiri Moskovcak 2010-11-18 20:34:17 UTC
*** Bug 654827 has been marked as a duplicate of this bug. ***

Comment 6 Wolfgang Ulbrich 2010-11-19 10:46:22 UTC
Package: abrt-1.1.14-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.try to send a bugreport with abrt
2.
3.


Comment
-----
nothing change with new abrt-version

Comment 7 Jiri Moskovcak 2010-11-19 12:10:13 UTC
This is weird, abrt-backtrace is not even used anymore

Comment 8 Jiri Moskovcak 2010-11-19 12:38:22 UTC
My guess here is that abrtd wasn't restarted after update (which would be a bug) or abrt-backtrace has been run manually (why?). Can you please check /var/log/messages and find out if abrtd has been restarted after you updated it?

Thank you.

Comment 9 Wolfgang Ulbrich 2010-11-20 01:15:50 UTC
Maybe the abrtd wasn't restartet when i try to write the bugreport.
I can't say it exactly because my /var/log/ directory is mounted as tmpfs, so messages are only for one system start. I don't have the old messages.
If abrt notice another bug i will try to test sending a bugreport, and give you a feedback if everything works fine or not.

thx

Comment 10 Wolfgang Ulbrich 2010-11-21 05:05:56 UTC
Ok, abrt seems to be fixed. I send a bugreport and abrt-1.1.14-1.fc14 works fine.

Thx for fixed it

Comment 11 Fedora Update System 2011-03-27 17:35:35 UTC
abrt-2.0.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-1.fc15

Comment 12 Fedora Update System 2011-03-29 20:00:44 UTC
abrt-2.0.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-2.fc15

Comment 13 Fedora Update System 2011-03-30 02:31:46 UTC
Package abrt-2.0.0-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.0-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/abrt-2.0.0-2.fc15
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2011-03-30 16:48:05 UTC
abrt-2.0.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-3.fc15

Comment 15 Fedora Update System 2011-04-04 14:07:47 UTC
abrt-2.0.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-4.fc15

Comment 16 Fedora Update System 2011-04-15 15:08:28 UTC
abrt-2.0.0-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-5.fc15

Comment 17 Fedora Update System 2011-04-20 13:29:20 UTC
abrt-2.0.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.1-1.fc15

Comment 18 Fedora Update System 2011-04-21 16:44:01 UTC
abrt-2.0.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.1-2.fc15

Comment 19 Fedora Update System 2011-04-26 16:11:25 UTC
abrt-2.0.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.