Bug 652995

Summary: SELinux is preventing /usr/bin/perl "node_bind" access .
Product: [Fedora] Fedora Reporter: srh <srhtemp1>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: dwalsh, mgrepl, trond.myklebust
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:ee5780d5d85df9597e89a8f05f9ffa6a8c70f6c1789a4b9cec9dfb542cf26b69
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-15 10:18:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description srh 2010-11-14 02:45:22 UTC
Summary:

SELinux is preventing /usr/bin/perl "node_bind" access .

Detailed Description:

SELinux denied access requested by ddclient. It is not expected that this access
is required by ddclient and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:ddclient_t:s0
Target Context                system_u:object_r:node_t:s0
Target Objects                None [ tcp_socket ]
Source                        ddclient
Source Path                   /usr/bin/perl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           perl-5.12.2-136.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.7-10.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35.6-48.fc14.x86_64 #1 SMP Fri
                              Oct 22 15:36:08 UTC 2010 x86_64 x86_64
Alert Count                   4
First Seen                    Sun 14 Nov 2010 15:20:23 NZDT
Last Seen                     Sun 14 Nov 2010 15:40:32 NZDT
Local ID                      81ff978b-b380-4719-840d-4c3aca5063b2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1289702432.266:39013): avc:  denied  { node_bind } for  pid=1588 comm="ddclient" scontext=system_u:system_r:ddclient_t:s0 tcontext=system_u:object_r:node_t:s0 tclass=tcp_socket

node=(removed) type=SYSCALL msg=audit(1289702432.266:39013): arch=c000003e syscall=49 success=no exit=-13 a0=4 a1=11b80a0 a2=10 a3=16aaa70 items=0 ppid=1 pid=1588 auid=4294967295 uid=489 gid=481 euid=489 suid=489 fsuid=489 egid=481 sgid=481 fsgid=481 tty=(none) ses=4294967295 comm="ddclient" exe="/usr/bin/perl" subj=system_u:system_r:ddclient_t:s0 key=(null)



Hash String generated from  catchall,ddclient,ddclient_t,node_t,tcp_socket,node_bind
audit2allow suggests:

#============= ddclient_t ==============
allow ddclient_t node_t:tcp_socket node_bind;

Comment 1 Miroslav Grepl 2010-11-15 10:18:08 UTC

*** This bug has been marked as a duplicate of bug 652965 ***