Bug 652965 - SELinux is preventing /usr/bin/perl "getattr" access on /tmp/ddclient.cache.
Summary: SELinux is preventing /usr/bin/perl "getattr" access on /tmp/ddclient.ca...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:d4c91d5edb3...
: 652966 652967 652994 652995 652999 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-13 21:15 UTC by Dan O'Brien
Modified: 2010-11-21 21:59 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-3.9.7-12.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-21 21:59:46 UTC
Type: ---


Attachments (Terms of Use)

Description Dan O'Brien 2010-11-13 21:15:44 UTC
Summary:

SELinux is preventing /usr/bin/perl "getattr" access on /tmp/ddclient.cache.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by ddclient. It is not expected that this access
is required by ddclient and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:ddclient_t:s0
Target Context                unconfined_u:object_r:initrc_tmp_t:s0
Target Objects                /tmp/ddclient.cache [ file ]
Source                        ddclient
Source Path                   /usr/bin/perl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           perl-5.12.2-136.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.7-10.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.35.6-48.fc14.x86_64 #1 SMP Fri Oct 22 15:36:08
                              UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Sat 13 Nov 2010 02:29:33 PM EST
Last Seen                     Sat 13 Nov 2010 03:04:36 PM EST
Local ID                      953d76f1-70a8-4594-a2f6-2faf20b11a58
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1289678676.440:35): avc:  denied  { getattr } for  pid=3268 comm="ddclient" path="/tmp/ddclient.cache" dev=dm-0 ino=19878 scontext=system_u:system_r:ddclient_t:s0 tcontext=unconfined_u:object_r:initrc_tmp_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1289678676.440:35): arch=c000003e syscall=4 success=yes exit=0 a0=913360 a1=8f1138 a2=8f1138 a3=1 items=0 ppid=1 pid=3268 auid=4294967295 uid=496 gid=493 euid=496 suid=496 fsuid=496 egid=493 sgid=493 fsgid=493 tty=(none) ses=4294967295 comm="ddclient" exe="/usr/bin/perl" subj=system_u:system_r:ddclient_t:s0 key=(null)



Hash String generated from  catchall,ddclient,ddclient_t,initrc_tmp_t,file,getattr
audit2allow suggests:

#============= ddclient_t ==============
allow ddclient_t initrc_tmp_t:file getattr;

Comment 1 Miroslav Grepl 2010-11-15 10:09:48 UTC
*** Bug 652966 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2010-11-15 10:10:11 UTC
*** Bug 652967 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2010-11-15 10:16:56 UTC
*** Bug 652994 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2010-11-15 10:18:08 UTC
*** Bug 652995 has been marked as a duplicate of this bug. ***

Comment 5 Miroslav Grepl 2010-11-15 10:20:21 UTC
*** Bug 652999 has been marked as a duplicate of this bug. ***

Comment 6 Miroslav Grepl 2010-11-15 10:24:55 UTC
Fixes for ddclient policy added to selinux-policy-3.9.7-13.fc14.

Comment 7 Fedora Update System 2010-11-19 13:21:31 UTC
selinux-policy-3.9.7-12.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-12.fc14

Comment 8 Fedora Update System 2010-11-19 22:39:45 UTC
selinux-policy-3.9.7-12.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-12.fc14

Comment 9 Fedora Update System 2010-11-21 21:58:08 UTC
selinux-policy-3.9.7-12.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.