Bug 657173

Summary: SELinux is preventing /usr/libexec/gam_server "getattr" access on /etc/rc.d/init.d/dnsmasq.
Product: [Fedora] Fedora Reporter: maurizio <antillon.maurizio>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:59f3006084686a98f23d9d8ea9cb83ab85ed038b84eec84a70fa0b726867cf6f
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-25 08:14:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description maurizio 2010-11-25 06:09:27 UTC
Summary:

SELinux is preventing /usr/libexec/gam_server "getattr" access on
/etc/rc.d/init.d/dnsmasq.

Detailed Description:

SELinux denied access requested by gam_server. It is not expected that this
access is required by gam_server and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:fail2ban_t:s0
Target Context                system_u:object_r:dnsmasq_initrc_exec_t:s0
Target Objects                /etc/rc.d/init.d/dnsmasq [ file ]
Source                        gam_server
Source Path                   /usr/libexec/gam_server
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gamin-0.1.10-7.fc13
Target RPM Packages           dnsmasq-2.52-1.fc13
Policy RPM                    selinux-policy-3.7.19-69.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.3-85.fc13.i686
                              #1 SMP Thu May 6 18:44:12 UTC 2010 i686 i686
Alert Count                   9
First Seen                    Mon 22 Nov 2010 09:01:38 PM MST
Last Seen                     Wed 24 Nov 2010 03:42:38 PM MST
Local ID                      8ee42595-690d-4a0c-9f21-1cedc05acde6
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1290638558.685:3376): avc:  denied  { getattr } for  pid=1549 comm="gam_server" path="/etc/rc.d/init.d/dnsmasq" dev=dm-0 ino=39973 scontext=system_u:system_r:fail2ban_t:s0 tcontext=system_u:object_r:dnsmasq_initrc_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1290638558.685:3376): arch=40000003 syscall=196 success=no exit=-13 a0=8f0acb0 a1=bfa3dfec a2=9ceff4 a3=100 items=0 ppid=1 pid=1549 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="gam_server" exe="/usr/libexec/gam_server" subj=system_u:system_r:fail2ban_t:s0 key=(null)



Hash String generated from  catchall,gam_server,fail2ban_t,dnsmasq_initrc_exec_t,file,getattr
audit2allow suggests:

#============= fail2ban_t ==============
allow fail2ban_t dnsmasq_initrc_exec_t:file getattr;

Comment 1 Miroslav Grepl 2010-11-25 08:14:26 UTC

*** This bug has been marked as a duplicate of bug 656127 ***