Bug 656127 - SELinux is preventing /usr/libexec/gam_server "getattr" access on /etc/rc.d/init.d/sshd.
Summary: SELinux is preventing /usr/libexec/gam_server "getattr" access on /etc/r...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:6c088091dc0...
: 656130 656135 656137 656140 656149 656153 656156 656159 656162 656165 656166 656168 657159 657161 657163 657168 657170 657171 657173 657176 657178 657180 657184 657185 657186 657190 657191 657193 658661 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-23 04:55 UTC by maurizio
Modified: 2010-12-01 09:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-23 11:38:30 UTC
Type: ---


Attachments (Terms of Use)

Description maurizio 2010-11-23 04:55:52 UTC
Summary:

SELinux is preventing /usr/libexec/gam_server "getattr" access on
/etc/rc.d/init.d/sshd.

Detailed Description:

SELinux denied access requested by gam_server. It is not expected that this
access is required by gam_server and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:fail2ban_t:s0
Target Context                system_u:object_r:sshd_initrc_exec_t:s0
Target Objects                /etc/rc.d/init.d/sshd [ file ]
Source                        gam_server
Source Path                   /usr/libexec/gam_server
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gamin-0.1.10-7.fc13
Target RPM Packages           openssh-server-5.4p1-1.fc13
Policy RPM                    selinux-policy-3.7.19-69.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.3-85.fc13.i686
                              #1 SMP Thu May 6 18:44:12 UTC 2010 i686 i686
Alert Count                   2
First Seen                    Mon 22 Nov 2010 09:01:38 PM MST
Last Seen                     Mon 22 Nov 2010 09:21:48 PM MST
Local ID                      d52b8221-3f17-4621-84a0-fbccf1401c09
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1290486108.706:12503): avc:  denied  { getattr } for  pid=1469 comm="gam_server" path="/etc/rc.d/init.d/sshd" dev=dm-0 ino=43103 scontext=system_u:system_r:fail2ban_t:s0 tcontext=system_u:object_r:sshd_initrc_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1290486108.706:12503): arch=40000003 syscall=196 success=no exit=-13 a0=9d4dfe8 a1=bfe960dc a2=9ceff4 a3=100 items=0 ppid=1 pid=1469 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="gam_server" exe="/usr/libexec/gam_server" subj=system_u:system_r:fail2ban_t:s0 key=(null)



Hash String generated from  catchall,gam_server,fail2ban_t,sshd_initrc_exec_t,file,getattr
audit2allow suggests:

#============= fail2ban_t ==============
allow fail2ban_t sshd_initrc_exec_t:file getattr;

Comment 1 Miroslav Grepl 2010-11-23 09:49:11 UTC
Can you turn off the gam_server by changing fail2ban to polling.

Comment 2 Miroslav Grepl 2010-11-23 10:11:34 UTC
*** Bug 656130 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2010-11-23 10:12:49 UTC
*** Bug 656135 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2010-11-23 10:13:17 UTC
*** Bug 656137 has been marked as a duplicate of this bug. ***

Comment 5 Miroslav Grepl 2010-11-23 10:27:36 UTC
*** Bug 656140 has been marked as a duplicate of this bug. ***

Comment 6 Miroslav Grepl 2010-11-23 10:28:16 UTC
*** Bug 656149 has been marked as a duplicate of this bug. ***

Comment 7 Miroslav Grepl 2010-11-23 10:29:52 UTC
*** Bug 656153 has been marked as a duplicate of this bug. ***

Comment 8 Miroslav Grepl 2010-11-23 10:30:16 UTC
*** Bug 656156 has been marked as a duplicate of this bug. ***

Comment 9 Miroslav Grepl 2010-11-23 10:36:15 UTC
*** Bug 656159 has been marked as a duplicate of this bug. ***

Comment 10 Miroslav Grepl 2010-11-23 10:36:48 UTC
*** Bug 656162 has been marked as a duplicate of this bug. ***

Comment 11 Miroslav Grepl 2010-11-23 10:39:41 UTC
*** Bug 656165 has been marked as a duplicate of this bug. ***

Comment 12 Miroslav Grepl 2010-11-23 10:40:27 UTC
*** Bug 656166 has been marked as a duplicate of this bug. ***

Comment 13 Miroslav Grepl 2010-11-23 10:40:56 UTC
*** Bug 656168 has been marked as a duplicate of this bug. ***

Comment 14 Daniel Walsh 2010-11-23 14:40:14 UTC
maurizio, if you see a ton of AVC errors that look the same, please report it once and then mention that you have a ton of them.  Otherwise we have to run through them all and close them as dups.  Thanks for reporting them though.

Comment 15 Miroslav Grepl 2010-11-25 08:11:35 UTC
*** Bug 657159 has been marked as a duplicate of this bug. ***

Comment 16 Miroslav Grepl 2010-11-25 08:12:14 UTC
*** Bug 657161 has been marked as a duplicate of this bug. ***

Comment 17 Miroslav Grepl 2010-11-25 08:12:50 UTC
*** Bug 657163 has been marked as a duplicate of this bug. ***

Comment 18 Miroslav Grepl 2010-11-25 08:13:12 UTC
*** Bug 657168 has been marked as a duplicate of this bug. ***

Comment 19 Miroslav Grepl 2010-11-25 08:13:38 UTC
*** Bug 657170 has been marked as a duplicate of this bug. ***

Comment 20 Miroslav Grepl 2010-11-25 08:14:04 UTC
*** Bug 657171 has been marked as a duplicate of this bug. ***

Comment 21 Miroslav Grepl 2010-11-25 08:14:26 UTC
*** Bug 657173 has been marked as a duplicate of this bug. ***

Comment 22 Miroslav Grepl 2010-11-25 08:14:49 UTC
*** Bug 657176 has been marked as a duplicate of this bug. ***

Comment 23 Miroslav Grepl 2010-11-25 08:15:15 UTC
*** Bug 657178 has been marked as a duplicate of this bug. ***

Comment 24 Miroslav Grepl 2010-11-25 08:15:36 UTC
*** Bug 657180 has been marked as a duplicate of this bug. ***

Comment 25 Miroslav Grepl 2010-11-25 08:16:07 UTC
*** Bug 657184 has been marked as a duplicate of this bug. ***

Comment 26 Miroslav Grepl 2010-11-25 08:16:38 UTC
*** Bug 657185 has been marked as a duplicate of this bug. ***

Comment 27 Miroslav Grepl 2010-11-25 08:17:10 UTC
*** Bug 657186 has been marked as a duplicate of this bug. ***

Comment 28 Miroslav Grepl 2010-11-25 08:17:49 UTC
*** Bug 657190 has been marked as a duplicate of this bug. ***

Comment 29 Miroslav Grepl 2010-11-25 08:18:19 UTC
*** Bug 657191 has been marked as a duplicate of this bug. ***

Comment 30 Miroslav Grepl 2010-11-25 08:18:49 UTC
*** Bug 657193 has been marked as a duplicate of this bug. ***

Comment 31 Miroslav Grepl 2010-11-25 13:10:53 UTC
maurizio,
have you read the comment #14?

Comment 32 Miroslav Grepl 2010-11-25 13:13:04 UTC
Use the following settings in /etc/fail2ban/jail.conf

---

# "backend" specifies the backend used to get files modification. Available
# options are "gamin", "polling" and "auto". This option can be overridden in
# each jail too (use "gamin" for a jail and "polling" for another).
#
# gamin:   requires Gamin (a file alteration monitor) to be installed. If Gamin
#          is not installed, Fail2ban will use polling.
# polling: uses a polling algorithm which does not require external libraries.
# auto:    will choose Gamin if available and polling otherwise.
backend = polling

---

Comment 33 Miroslav Grepl 2010-12-01 09:01:00 UTC
*** Bug 658661 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.