Bug 660139

Summary: New pyPdf release available
Product: [Fedora] Fedora Reporter: Fabian Affolter <mail>
Component: pyPdfAssignee: Felix Schwarz <fschwarz>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: chkr, fschwarz, kylev, upstream-release-monitoring
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-27 20:02:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 650424    

Description Fabian Affolter 2010-12-05 19:39:35 UTC
- Fixed a typo in code for reading a "\b" escape character in strings.
 - Improved __repr__ in FloatObject.
 - Fixed a bug in reading octal escape sequences in strings.
 - Added getWidth and getHeight methods to the RectangleObject class.
 - Fixed compatibility warnings with Python 2.4 and 2.5.
 - Added addBlankPage and insertBlankPage methods on PdfFileWriter class.
 - Fixed a bug with circular references in page's object trees (typically
   annotations) that prevented correctly writing out a copy of those pages.
 - New merge page functions allow application of a transformation matrix.
 - To all patch contributors: I did a poor job of keeping this ChangeLog
   up-to-date for this release, so I an missing attributions here for any
   changes you submitted.  Sorry!  I'll do better in the future.

Comment 1 Felix Schwarz 2010-12-08 21:03:43 UTC
*** Bug 661477 has been marked as a duplicate of this bug. ***

Comment 2 Felix Schwarz 2010-12-27 20:02:17 UTC
pyPdf 1.13 is now available in rawhide, thanks for your patience.

Comment 3 Christian Krause 2011-03-20 23:25:50 UTC
(In reply to comment #2)
> pyPdf 1.13 is now available in rawhide, thanks for your patience.

Please can you update pyPdf in F15, F14 and F13 as well? In Fedora calibre is using this external pyPdf library instead its private one where one of the mentioned bugs (the typo for "\b") was explicitly fixed.

If you don't have time, I could quickly do the update. Please let me know whether this would be OK with you.

Comment 4 Felix Schwarz 2011-03-21 15:19:54 UTC
(In reply to comment #3)
> If you don't have time, I could quickly do the update. Please let me know
> whether this would be OK with you.

I did not update pyPdf F13/F14 because I tried to be careful with respect to possible incompatibilities (though I don't think there are any). F15 is definitively an oversight by me.

So if you also assume that 1.13 is a compatible upgrade for 1.12, just go ahead and commit the update.

Comment 5 Christian Krause 2011-03-22 07:55:01 UTC
(In reply to comment #4)
> I did not update pyPdf F13/F14 because I tried to be careful with respect to
> possible incompatibilities (though I don't think there are any). F15 is
> definitively an oversight by me.

Sorry, F15 is fine. I have overseen that the update happened before F15 was split off.

> So if you also assume that 1.13 is a compatible upgrade for 1.12, just go ahead
> and commit the update.

I have quickly checked the API and I haven't found any incompatible changes.

The following packages depend on pyPdf in Fedora: calibre, pdfposter and pdfshuffler. I have tested all of them and I haven't seen any issues so far.

So I've built the updates for F13 and F14 as well. Once they are in updates-testing, I'll mail the packagers of pdfposter and pdfshuffler to test it as well. That way we should be on the safe side not causing any breakage.

Comment 6 Fedora Update System 2011-03-22 22:33:42 UTC
pyPdf-1.13-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/pyPdf-1.13-1.fc13

Comment 7 Fedora Update System 2011-03-22 22:34:34 UTC
pyPdf-1.13-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pyPdf-1.13-1.fc14

Comment 8 Fedora Update System 2011-04-09 21:18:25 UTC
pyPdf-1.13-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-04-09 21:18:34 UTC
pyPdf-1.13-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.