Bug 661600

Summary: lxdm cannot start due to bogus X parameter -nr
Product: [Fedora] Fedora Reporter: Andy Clark <andrewclarkii>
Component: lxdmAssignee: Christoph Wickert <cwickert>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: low    
Version: rawhideCC: awilliam, cwickert, jlaska, mattdm
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: lxdm-0.3.0-4.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-18 04:03:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 657617    
Description Flags
messages file
lxdm log file none

Description Andy Clark 2010-12-09 07:04:13 UTC
Description of problem:
after "yum update" my Fedora system, desktop manager can't start.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info: workaround problem - after booting in runlevel 5, login to another terminal window by pressing ALT+F2, for example. When user enter login and password (this is not easy, because system is switching screen back to system tty time to time), then he must switch system to runlevel 3 (telinit 3 with root user privileges). switch back to user account and run XWindow system by typing "startx" in terminal. By the way - when we change runlevel, we need to restart crond daemon (/etc/init.d/crond stop/start), because it stop working after changing runlevel. 
[root@timelock andy]# chkconfig --list | grep crond
crond          	0:off	1:off	2:on	3:on	4:on	5:on	6:off
[root@timelock andy]#

Comment 1 Andy Clark 2010-12-09 07:05:01 UTC
Created attachment 467691 [details]
messages file

Comment 2 Andy Clark 2010-12-09 07:05:38 UTC
Created attachment 467692 [details]
lxdm log file

Comment 3 Adam Williamson 2011-01-11 15:02:23 UTC
it looks like lxdm is calling X with bad options, so, lxdm bug? does it work if you switch to gdm?

Fedora Bugzappers volunteer triage team

Comment 4 Adam Williamson 2011-01-11 15:03:11 UTC

Fedora Bugzappers volunteer triage team

Comment 5 Adam Williamson 2011-01-11 15:03:23 UTC

Fedora Bugzappers volunteer triage team

Comment 6 Christoph Wickert 2011-01-17 10:40:31 UTC
Where are these options coming from? Did you start lxdm manually?

Please give us the content of


Thanks in advance.

Comment 7 Andy Clark 2011-01-17 10:49:27 UTC
i don't try gdm yet, but thank you for your answer

[andy@timelock ~]$ cat /etc/sysconfig/desktop
[andy@timelock ~]$ cat /etc/lxdm/lxdm.conf
cat: /etc/lxdm/lxdm.conf: Permission denied
[andy@timelock ~]$ su -
[root@timelock ~]# cat /etc/lxdm/lxdm.conf
# autologin=dgod
# session=/usr/bin/startlxde
# numlock=0

arg=/usr/bin/X -nr vt1




[root@timelock ~]#

Comment 8 Christoph Wickert 2011-01-17 11:37:02 UTC
Ok, lxdm.conf is fine. It looks you are running systemd, right? What happens if you comment out the line starting with arg=... ?

Can you tell me what package versions you are using?

rpm -q fedora-release lxdm systemd systemd-sysvinit systemd-utils

Comment 9 Andy Clark 2011-01-17 11:56:20 UTC
I'm using rawhide and yes, i'm using systemd. Version of packages:

[andy@timelock ~]$ rpm -qa | egrep "(fedora-release|lxdm|systemd)"
[andy@timelock ~]$

You want what I would comment out the line in the file /etc/lxdm/lxdm.conf in [server] stanza?

Comment 10 Andy Clark 2011-01-17 12:10:16 UTC
I saw lxdm login, when i'm comment out /etc/lxdm/lxdm.conf:

#arg=/usr/bin/X -nr vt1

but i can't log in, because, after i enter my login and password -
lxdm displays login again and again (infinite loop).

Comment 11 Christoph Wickert 2011-01-17 19:22:17 UTC
Can you try with selinux in permissive mode just to be sure? Can you login in runlevel 3 and run LXDE with startlxde?

Comment 12 Adam Williamson 2011-01-17 20:10:10 UTC
christoph: I just hit this bug testing something (I had to use lxdm as gdm in Rawhide live images appears to be broken). The bad -nr parameter is indeed in lxdm.conf out of the box - after a fresh install of lxdm - and it prevents lxdm from running. If I remove it from lxdm.conf, lxdm runs, and I could log in (I didn't hit the infinite loop Andy hit).

Fedora Bugzappers volunteer triage team

Comment 13 Christoph Wickert 2011-01-17 21:07:05 UTC
Thanks for testing, Adam. On which VT is LXDM starting?

/me needs to set up a rawhide box...

Comment 14 Adam Williamson 2011-01-17 21:32:38 UTC
honestly, I didn't check, I was at the end of my tether just trying to test the damn thing I was testing so once I got LXDM to start, I didn't investigate further =)

Fedora Bugzappers volunteer triage team

Comment 15 Andy Clark 2011-01-28 09:36:32 UTC
what i'm need to do?

Comment 16 Matthew Miller 2011-02-13 22:18:11 UTC
I just ran into this, and tested it. With the config file line changed to:

arg=/usr/bin/X vt1

(That is, just remove the '-nr'), everything works fine and LXDM starts on vt1.

`man Xorg` gives no mention of this `nr` option, but I found something about it here: http://www.mail-archive.com/xorg-devel@lists.x.org/msg09360.html, and further digging suggests it's something to do with "smooth Plymouth -> X transitions", which is of course little consolation if one is getting no login manager.

So, uh, does someone know what it's supposed to do? I think the right thing is to not encode any fancy X options in per-display-manager config files, but may

Comment 17 Adam Williamson 2011-02-16 20:26:05 UTC
changing the summary so we can find this damn thing better.

I think what this is meant to do is tell X to start on vt1 (not vt7), which does indeed help with smooth plymouth -> LXDE transition, but it's hardly critical. I think if we can't figure out the correct form of the parameter in current X we should just drop it for now. This currently breaks the LXDE spin for F15 Alpha.

Comment 18 Adam Williamson 2011-02-16 20:27:10 UTC
hum, actually, just the 'vt1' alone should do that. So I don't know what the -nr is for.

Comment 19 Adam Williamson 2011-02-16 20:31:15 UTC
this has been changed in the last two upstream commits:


I will commit the relevant changes to our lxdm and see if that fixes it.

Comment 20 Fedora Update System 2011-02-17 03:15:00 UTC
lxdm-0.3.0-4.fc15 has been submitted as an update for Fedora 15.

Comment 21 Adam Williamson 2011-02-17 07:45:45 UTC
if people could test and +1 the update it'd really help. I have tested it in a live image I built here and it worked fine.

Comment 22 Andy Clark 2011-02-17 08:03:57 UTC
After i'm removed "-nr" option, lxdm works fine.
[andy@timelock tmp]$ rpm -qa | grep lxdm
[andy@timelock tmp]$
But i have not tried "-background" option.

Comment 23 Adam Williamson 2011-02-17 08:13:48 UTC
please just test by installing the updated package from updates-testing or koji and report success or failure to bodhi via the link above. thanks!

Comment 24 Andy Clark 2011-02-17 08:55:31 UTC
i'm downloaded package from link above, and installed this package in my system:
[andy@timelock ~]$ rpm -qa | grep lxdm
[andy@timelock ~]$
Problem solved, you may close this bug. Adam, Christoph, Matthew - thank you very much!

Comment 25 Matthew Miller 2011-02-17 13:58:42 UTC
Is the new option working as intended, or should it be "-background none"?

I also note that my existing config file got moved to .rpmsave, instead of getting an .rpmnew file. If I had configured other things (like autologin), I would have preferred that to be preserved.

Comment 26 Andy Clark 2011-02-17 14:28:04 UTC
New option working as "-background vt1"
[root@timelock ~]# cat /etc/lxdm/lxdm.conf
# autologin=dgod
# session=/usr/bin/startlxde
# numlock=0

arg=/usr/bin/X -background vt1




[root@timelock ~]#

Comment 27 Adam Williamson 2011-02-17 16:49:23 UTC
matthew: just plain '-background' is what upstream has; I actually just re-diffed an upstream patch. If you run X with some garbage options, to see the help output, it shows:

-background [none]     create root window with no background

the square brackets indicating the none is optional. X has a somewhat odd convention that the minus sign in some parameters is taken *literally* and means 'disable this' - so -background can be read 'minus background' and means 'disable the background'. See also -xinerama , for instance - you might think it means 'use xinerama', but you'd be dead wrong. =)

Comment 28 Matthew Miller 2011-02-17 17:36:57 UTC
Okay, sounds good. I still think it should be config(noreplace), but that's a separate bug.

Comment 29 Christoph Wickert 2011-02-17 17:51:55 UTC
(In reply to comment #28)
> Okay, sounds good. I still think it should be config(noreplace), but that's a
> separate bug.

In fact removing (noreplace) was the result of a another bug. We need to make sure that lxdm is operational after an update and we can only guarantee that with a new config file because the behavior of lxdm has changed quite often in the past.

Sorry I have been so unresponsive in this bug, I'm just too busy with my dayjob. A big thanks to Adam for taking over!

Comment 30 James Laska 2011-02-17 20:16:34 UTC
+1 to including this as a nice-to-have (NTH) bug.  This issue adheres to the NTH principles [1]

[1] https://fedoraproject.org/wiki/QA:SOP_nth_bug_process#Nice-to-have_bug_principles

Comment 31 Dennis Gilmore 2011-02-17 21:18:42 UTC
+1 to including as a HTH bug

Comment 32 Adam Williamson 2011-02-17 21:25:46 UTC
thanks - can you push it through the freeze, then?

Comment 33 Fedora Update System 2011-02-18 04:03:13 UTC
lxdm-0.3.0-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.