Bug 661600 - lxdm cannot start due to bogus X parameter -nr
lxdm cannot start due to bogus X parameter -nr
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxdm (Show other bugs)
rawhide
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15Alpha-accepted/F15AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2010-12-09 02:04 EST by Andy Clark
Modified: 2011-02-17 23:03 EST (History)
4 users (show)

See Also:
Fixed In Version: lxdm-0.3.0-4.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-17 23:03:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages file (62.68 KB, text/plain)
2010-12-09 02:05 EST, Andy Clark
no flags Details
lxdm log file (6.21 KB, text/plain)
2010-12-09 02:05 EST, Andy Clark
no flags Details

  None (edit)
Description Andy Clark 2010-12-09 02:04:13 EST
Description of problem:
after "yum update" my Fedora system, desktop manager can't start.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: workaround problem - after booting in runlevel 5, login to another terminal window by pressing ALT+F2, for example. When user enter login and password (this is not easy, because system is switching screen back to system tty time to time), then he must switch system to runlevel 3 (telinit 3 with root user privileges). switch back to user account and run XWindow system by typing "startx" in terminal. By the way - when we change runlevel, we need to restart crond daemon (/etc/init.d/crond stop/start), because it stop working after changing runlevel. 
[root@timelock andy]# chkconfig --list | grep crond
crond          	0:off	1:off	2:on	3:on	4:on	5:on	6:off
[root@timelock andy]#
Comment 1 Andy Clark 2010-12-09 02:05:01 EST
Created attachment 467691 [details]
messages file
Comment 2 Andy Clark 2010-12-09 02:05:38 EST
Created attachment 467692 [details]
lxdm log file
Comment 3 Adam Williamson 2011-01-11 10:02:23 EST
it looks like lxdm is calling X with bad options, so, lxdm bug? does it work if you switch to gdm?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2011-01-11 10:03:11 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2011-01-11 10:03:23 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Christoph Wickert 2011-01-17 05:40:31 EST
Where are these options coming from? Did you start lxdm manually?

Please give us the content of

/etc/lxdm/lxdm.conf
/etc/sysconfig/desktop

Thanks in advance.
Comment 7 Andy Clark 2011-01-17 05:49:27 EST
i don't try gdm yet, but thank you for your answer

[andy@timelock ~]$ cat /etc/sysconfig/desktop
PREFERRED=/usr/bin/startlxde
DISPLAYMANAGER=/usr/sbin/lxdm
[andy@timelock ~]$ cat /etc/lxdm/lxdm.conf
cat: /etc/lxdm/lxdm.conf: Permission denied
[andy@timelock ~]$ su -
Password: 
[root@timelock ~]# cat /etc/lxdm/lxdm.conf
[base]
# autologin=dgod
# session=/usr/bin/startlxde
# numlock=0
greeter=/usr/libexec/lxdm-greeter-gtk

[server]
arg=/usr/bin/X -nr vt1

[display]
gtk_theme=Clearlooks
bg=/usr/share/backgrounds/default.png
bottom_pane=1
lang=1
theme=Industrial

[input]

[userlist]
disable=0
white=
black=

[root@timelock ~]#
Comment 8 Christoph Wickert 2011-01-17 06:37:02 EST
Ok, lxdm.conf is fine. It looks you are running systemd, right? What happens if you comment out the line starting with arg=... ?

Can you tell me what package versions you are using?

rpm -q fedora-release lxdm systemd systemd-sysvinit systemd-utils
Comment 9 Andy Clark 2011-01-17 06:56:20 EST
I'm using rawhide and yes, i'm using systemd. Version of packages:

[andy@timelock ~]$ rpm -qa | egrep "(fedora-release|lxdm|systemd)"
systemd-units-16-1.fc15.i686
fedora-release-notes-14.1.2-1.fc15.noarch
systemd-16-1.fc15.i686
lxdm-0.3.0-2.fc15.i686
[andy@timelock ~]$

You want what I would comment out the line in the file /etc/lxdm/lxdm.conf in [server] stanza?
Comment 10 Andy Clark 2011-01-17 07:10:16 EST
I saw lxdm login, when i'm comment out /etc/lxdm/lxdm.conf:

[server]
#arg=/usr/bin/X -nr vt1

but i can't log in, because, after i enter my login and password -
lxdm displays login again and again (infinite loop).
Comment 11 Christoph Wickert 2011-01-17 14:22:17 EST
Can you try with selinux in permissive mode just to be sure? Can you login in runlevel 3 and run LXDE with startlxde?
Comment 12 Adam Williamson 2011-01-17 15:10:10 EST
christoph: I just hit this bug testing something (I had to use lxdm as gdm in Rawhide live images appears to be broken). The bad -nr parameter is indeed in lxdm.conf out of the box - after a fresh install of lxdm - and it prevents lxdm from running. If I remove it from lxdm.conf, lxdm runs, and I could log in (I didn't hit the infinite loop Andy hit).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Christoph Wickert 2011-01-17 16:07:05 EST
Thanks for testing, Adam. On which VT is LXDM starting?

/me needs to set up a rawhide box...
Comment 14 Adam Williamson 2011-01-17 16:32:38 EST
honestly, I didn't check, I was at the end of my tether just trying to test the damn thing I was testing so once I got LXDM to start, I didn't investigate further =)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Andy Clark 2011-01-28 04:36:32 EST
what i'm need to do?
Comment 16 Matthew Miller 2011-02-13 17:18:11 EST
I just ran into this, and tested it. With the config file line changed to:

arg=/usr/bin/X vt1

(That is, just remove the '-nr'), everything works fine and LXDM starts on vt1.

`man Xorg` gives no mention of this `nr` option, but I found something about it here: http://www.mail-archive.com/xorg-devel@lists.x.org/msg09360.html, and further digging suggests it's something to do with "smooth Plymouth -> X transitions", which is of course little consolation if one is getting no login manager.

So, uh, does someone know what it's supposed to do? I think the right thing is to not encode any fancy X options in per-display-manager config files, but may
Comment 17 Adam Williamson 2011-02-16 15:26:05 EST
changing the summary so we can find this damn thing better.

I think what this is meant to do is tell X to start on vt1 (not vt7), which does indeed help with smooth plymouth -> LXDE transition, but it's hardly critical. I think if we can't figure out the correct form of the parameter in current X we should just drop it for now. This currently breaks the LXDE spin for F15 Alpha.
Comment 18 Adam Williamson 2011-02-16 15:27:10 EST
hum, actually, just the 'vt1' alone should do that. So I don't know what the -nr is for.
Comment 19 Adam Williamson 2011-02-16 15:31:15 EST
this has been changed in the last two upstream commits:

http://lxde.git.sourceforge.net/git/gitweb.cgi?p=lxde/lxdm;a=history;f=data/lxdm.conf.in;h=7cb5f8747ad8e3494455d4979f54e9deee18771f;hb=HEAD

I will commit the relevant changes to our lxdm and see if that fixes it.
Comment 20 Fedora Update System 2011-02-16 22:15:00 EST
lxdm-0.3.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lxdm-0.3.0-4.fc15
Comment 21 Adam Williamson 2011-02-17 02:45:45 EST
if people could test and +1 the update it'd really help. I have tested it in a live image I built here and it worked fine.
Comment 22 Andy Clark 2011-02-17 03:03:57 EST
After i'm removed "-nr" option, lxdm works fine.
[andy@timelock tmp]$ rpm -qa | grep lxdm
lxdm-0.3.0-3.fc15.i686
[andy@timelock tmp]$
But i have not tried "-background" option.
Comment 23 Adam Williamson 2011-02-17 03:13:48 EST
please just test by installing the updated package from updates-testing or koji and report success or failure to bodhi via the link above. thanks!
Comment 24 Andy Clark 2011-02-17 03:55:31 EST
i'm downloaded package from link above, and installed this package in my system:
[andy@timelock ~]$ rpm -qa | grep lxdm
lxdm-0.3.0-4.fc15.i686
[andy@timelock ~]$
Problem solved, you may close this bug. Adam, Christoph, Matthew - thank you very much!
Comment 25 Matthew Miller 2011-02-17 08:58:42 EST
Is the new option working as intended, or should it be "-background none"?

I also note that my existing config file got moved to .rpmsave, instead of getting an .rpmnew file. If I had configured other things (like autologin), I would have preferred that to be preserved.
Comment 26 Andy Clark 2011-02-17 09:28:04 EST
New option working as "-background vt1"
[root@timelock ~]# cat /etc/lxdm/lxdm.conf
[base]
# autologin=dgod
# session=/usr/bin/startlxde
# numlock=0
greeter=/usr/libexec/lxdm-greeter-gtk

[server]
arg=/usr/bin/X -background vt1

[display]
gtk_theme=Clearlooks
bg=/usr/share/backgrounds/default.png
bottom_pane=1
lang=1
theme=Industrial

[input]

[userlist]
disable=0
white=
black=

[root@timelock ~]#
Comment 27 Adam Williamson 2011-02-17 11:49:23 EST
matthew: just plain '-background' is what upstream has; I actually just re-diffed an upstream patch. If you run X with some garbage options, to see the help output, it shows:

-background [none]     create root window with no background

the square brackets indicating the none is optional. X has a somewhat odd convention that the minus sign in some parameters is taken *literally* and means 'disable this' - so -background can be read 'minus background' and means 'disable the background'. See also -xinerama , for instance - you might think it means 'use xinerama', but you'd be dead wrong. =)
Comment 28 Matthew Miller 2011-02-17 12:36:57 EST
Okay, sounds good. I still think it should be config(noreplace), but that's a separate bug.
Comment 29 Christoph Wickert 2011-02-17 12:51:55 EST
(In reply to comment #28)
> Okay, sounds good. I still think it should be config(noreplace), but that's a
> separate bug.

In fact removing (noreplace) was the result of a another bug. We need to make sure that lxdm is operational after an update and we can only guarantee that with a new config file because the behavior of lxdm has changed quite often in the past.

Sorry I have been so unresponsive in this bug, I'm just too busy with my dayjob. A big thanks to Adam for taking over!
Comment 30 James Laska 2011-02-17 15:16:34 EST
+1 to including this as a nice-to-have (NTH) bug.  This issue adheres to the NTH principles [1]

[1] https://fedoraproject.org/wiki/QA:SOP_nth_bug_process#Nice-to-have_bug_principles
Comment 31 Dennis Gilmore 2011-02-17 16:18:42 EST
+1 to including as a HTH bug
Comment 32 Adam Williamson 2011-02-17 16:25:46 EST
thanks - can you push it through the freeze, then?
Comment 33 Fedora Update System 2011-02-17 23:03:13 EST
lxdm-0.3.0-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.