Bug 667031

Summary: ibus requires dbus-x11
Product: Red Hat Enterprise Linux 6 Reporter: fujiwara <tfujiwar>
Component: ibusAssignee: fujiwara <tfujiwar>
Status: CLOSED ERRATA QA Contact: QE Internationalization Bugs <qe-i18n-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: 6.2CC: ajb, amyagi, eng-i18n-bugs, ktakemur, msvoboda, scottro11, tfujiwar
Target Milestone: rcKeywords: i18n
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: ibus-1.3.4-6.el6 Doc Type: Bug Fix
Doc Text:
IBus did not work on a minimal installation of Red Hat Enterprise Linux 6 if no desktop environment, such as KDE or GNOME, was installed. This issue was caused by the missing dbus-x11 package, which IBus is dependent on. The dbus-x11 package is now included as a prerequisite for IBus in the IBus spec file, and IBus now works as expected.
Story Points: ---
Clone Of: 666427 Environment:
Last Closed: 2011-12-06 16:18:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 666427    
Bug Blocks:    

Description fujiwara 2011-01-04 06:11:09 UTC
+++ This bug was initially created as a clone of Bug #666427 +++

Description of problem:
If doing a minimal installation and adding X afterwards, without adding a Desktop environment, ibus fails to work. 


Version-Release number of selected component (if applicable):



How reproducible:



Steps to Reproduce:
1. Do minimal installation
2.Install X afterwards, then a window manager, vs. a desktop environmentthen install ibus-anthy
3.Start X and run ibus-setup
  
Actual results:

After one selects the input manager, the setting doesn't hold.  If one re-runs ibus-setup, there is no manager selected. 


Expected results:
ibus should work without the necessity of installing Gnome or KDE.  (Or possibly other Desktop Environments).  


Additional info:
Installing kdebase will enable it to work as expected.  This is a package problem with RH--the same issue occurs in ScientificLinux 6 alpha and therefore RH6 almost certainly has the same problem.  

The reason I believe that this is a RH bug, rather than ibus bug is that it works as expected in ArchLinux--their packaging apparently includes all necessary dependencies.   By doing things such as installing gnome-terminal, which will pull in another group of dependencies, one can get it to semi-work--that is, it will work with some expected applications but not others.   As mentioned, if I install kdebase, everything will work as it should.

--- Additional comment from scottro11@gmail.com on 2010-12-31 19:27:26 EST ---

It turned out, upon testing with further installs, that kdebase didn't fix the issue.  However, by comparing it with a Debian installation, where it works as it should, the missing dependency seems to be dbus-x11.  Upon installing that, it works as expected.   

This also holds for Scientific Linux's 6 alpha, based on RHEL6, so perhaps someone could notify them as well.

--- Additional comment from tfujiwar@redhat.com on 2011-01-03 21:52:28 EST ---

Do you mean your problem is fixed when you install dbus-x11?
I guess you use TWM.

--- Additional comment from scottro11@gmail.com on 2011-01-03 22:00:35 EST ---

Yes, if one install dbus-x11, ibus works with any window manager.    For testing, I redid the Scientific Linux ibus spec file, (taken from RHEL6, as far as I know), just adding the line Requires: dbus-x11 and it then works with all window managers.  

(I primarily use either openbox or fluxbox, but if one adds dbus-x11, it works with all of them, including twm.)  

Thank you for your quick response.  
(Note that this problem occurs not only with Fedora, but also with Scientific Linux, and, I would guess, RHEL6.)

--- Additional comment from tfujiwar@redhat.com on 2011-01-03 22:22:11 EST ---

Thanks for the report.
I will update Fedora 14 & 13.
Probably I think we will not update RHEL6. If you wish, probably I think we can fix RHEL6.2.

--- Additional comment from scottro11@gmail.com on 2011-01-03 23:40:09 EST ---

Thank you for your time.  Even if it doesn't affect too many people, as it is just a matter of adding Requires: dbus-x11 to the ibus spec file, hopefully, the process of getting it into RH won't be too time consuming.  

Once again, thank you for your time and efforts.

--- Additional comment from tfujiwar@redhat.com on 2011-01-03 23:42:20 EST ---

http://pkgs.fedoraproject.org/gitweb/?p=ibus.git;a=blobdiff;f=ibus.spec;h=50cb8ac9c019b10c9dc545ede7f15fc129681872;hp=6fa7f1d0ba1919c1e4195637360756e5a5fa2faf;hb=f2b74932a66b66dabbce26805e90b40192d2d6ee;hpb=aa00a29e99a61a0949bf7b1fc54e91ec0218b0ea

--- Additional comment from updates@fedoraproject.org on 2011-01-03 23:56:50 EST ---

ibus-1.3.9-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ibus-1.3.9-2.fc14

--- Additional comment from updates@fedoraproject.org on 2011-01-04 00:12:52 EST ---

ibus-1.3.9-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/ibus-1.3.9-2.fc13

Comment 2 Akemi Yagi 2011-01-04 16:35:34 UTC
Thanks for initiating this bug report for RHEL-6. 

Anyone wishing to test the ibus package with the proposed patch can download the RHEL-6 version ( ibus-1.3.4-3.el6.bug667031 ) from:

http://linux.toracat.org/EL/misc/ibus/

Comment 3 Scott Robbins 2011-01-05 00:47:11 UTC
I have tested Akemi-san's ibus.  I did an absolute minimal install of Scientific Linux, then, after updating, did yum install xorg-x11-\* xterm and hal.  

Then I installed ibus-anthy.  Result was as expected, after running ibus-setup and adding anthy, when I ran ibus-setup again anthy was not listed. 

Uninstalled ibus-\* and installed ibus packages provided by Akemi-san.  Reinstalled ibus-anthy, and, using twm was able to add anthy as input manager and input Japanese as expected.  So, it definitely works. 


Many thanks for your efforts.  I'll be trying the Fedora version later tonight, and will post to that bug.

Comment 9 Miroslav Svoboda 2011-08-26 11:46:12 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
IBus did not work on a minimal installation of Red Hat Enterprise Linux 6 if no desktop environment, such as KDE or GNOME, was installed. This issue was caused by the missing dbus-x11 package, which IBus is dependent on. The dbus-x11 package is now included as a prerequisite for IBus in the IBus spec file, and IBus now works as expected.

Comment 10 errata-xmlrpc 2011-12-06 16:18:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1645.html