Bug 666427 - ibus requires dbus-x11
ibus requires dbus-x11
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 667031
  Show dependency treegraph
 
Reported: 2010-12-30 12:09 EST by Scott Robbins
Modified: 2011-01-12 00:21 EST (History)
6 users (show)

See Also:
Fixed In Version: ibus-1.3.9-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 667031 (view as bug list)
Environment:
Last Closed: 2011-01-08 16:26:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Robbins 2010-12-30 12:09:14 EST
Description of problem:
If doing a minimal installation and adding X afterwards, without adding a Desktop environment, ibus fails to work. 


Version-Release number of selected component (if applicable):



How reproducible:



Steps to Reproduce:
1. Do minimal installation
2.Install X afterwards, then a window manager, vs. a desktop environmentthen install ibus-anthy
3.Start X and run ibus-setup
  
Actual results:

After one selects the input manager, the setting doesn't hold.  If one re-runs ibus-setup, there is no manager selected. 


Expected results:
ibus should work without the necessity of installing Gnome or KDE.  (Or possibly other Desktop Environments).  


Additional info:
Installing kdebase will enable it to work as expected.  This is a package problem with RH--the same issue occurs in ScientificLinux 6 alpha and therefore RH6 almost certainly has the same problem.  

The reason I believe that this is a RH bug, rather than ibus bug is that it works as expected in ArchLinux--their packaging apparently includes all necessary dependencies.   By doing things such as installing gnome-terminal, which will pull in another group of dependencies, one can get it to semi-work--that is, it will work with some expected applications but not others.   As mentioned, if I install kdebase, everything will work as it should.
Comment 1 Scott Robbins 2010-12-31 19:27:26 EST
It turned out, upon testing with further installs, that kdebase didn't fix the issue.  However, by comparing it with a Debian installation, where it works as it should, the missing dependency seems to be dbus-x11.  Upon installing that, it works as expected.   

This also holds for Scientific Linux's 6 alpha, based on RHEL6, so perhaps someone could notify them as well.
Comment 2 fujiwara 2011-01-03 21:52:28 EST
Do you mean your problem is fixed when you install dbus-x11?
I guess you use TWM.
Comment 3 Scott Robbins 2011-01-03 22:00:35 EST
Yes, if one install dbus-x11, ibus works with any window manager.    For testing, I redid the Scientific Linux ibus spec file, (taken from RHEL6, as far as I know), just adding the line Requires: dbus-x11 and it then works with all window managers.  

(I primarily use either openbox or fluxbox, but if one adds dbus-x11, it works with all of them, including twm.)  

Thank you for your quick response.  
(Note that this problem occurs not only with Fedora, but also with Scientific Linux, and, I would guess, RHEL6.)
Comment 4 fujiwara 2011-01-03 22:22:11 EST
Thanks for the report.
I will update Fedora 14 & 13.
Probably I think we will not update RHEL6. If you wish, probably I think we can fix RHEL6.2.
Comment 5 Scott Robbins 2011-01-03 23:40:09 EST
Thank you for your time.  Even if it doesn't affect too many people, as it is just a matter of adding Requires: dbus-x11 to the ibus spec file, hopefully, the process of getting it into RH won't be too time consuming.  

Once again, thank you for your time and efforts.
Comment 7 Fedora Update System 2011-01-03 23:56:50 EST
ibus-1.3.9-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ibus-1.3.9-2.fc14
Comment 8 Fedora Update System 2011-01-04 00:12:52 EST
ibus-1.3.9-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/ibus-1.3.9-2.fc13
Comment 9 Fedora Update System 2011-01-04 15:54:25 EST
ibus-1.3.9-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/ibus-1.3.9-2.fc13
Comment 10 Scott Robbins 2011-01-04 20:05:11 EST
I just did a fresh minimal installation of Fedora to test.  I guess the new ibus-1.3.9-2.fc14 hasn't made it to all mirrors yet, as I was only able to get 1.3.9-1.fc14.  However, enabling updates-testing enabled me to get the 1.3.9-2 version.  

It works perfectly.  Did a minimal installation, then installed X and openbox.  I then installed (using updates-testing) ibus-anthy, which brought in the new ibus.  

Ran ibus-setup added Anthy, ran it again and Anthy was still there.   Entering Japanese worked without problem.

So, many, many thanks for your VERY quick work with this.
Comment 11 Fedora Update System 2011-01-08 16:26:41 EST
ibus-1.3.9-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Scott Robbins 2011-01-08 19:23:03 EST
Thank you--just tested with a fresh install and it works perfectly.
Comment 13 Fedora Update System 2011-01-12 00:21:08 EST
ibus-1.3.9-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.