This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 668084

Summary: Installation available to an unnecessarily limited set of keyboard layouts
Product: [Fedora] Fedora Reporter: Jean-François Fortin Tam <nekohayo>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 16CC: aalam, anaconda-maint-list, duffy, g.kaviyarasu, i18n-bugs, jonathan, kraymond, madko, marbolangos, myllynen, ploum, ricardo.arguello, sebastien.willmann, vanmeeuwen+fedora, vcrhonek
Target Milestone: ---Keywords: i18n
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: anaconda-18.3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-03 15:27:36 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 680990    
Bug Blocks:    

Description Jean-François Fortin Tam 2011-01-07 15:37:58 EST
GNOME provides a French dvorak keyboard layout for Canada. In installers such as ubiquity, this layout can be used directly. 

However, this choice isn't available in Fedora's installer, as it seems to use a different set of keyboard layouts than the one GNOME provides.

I'm therefore forced to install my system with an incorrect keyboard layout, and have to figure out how to set the defaults properly in GDM, the consoles, etc.

It's kind of a big deal for me that keyboard layouts available at install time don't match 1:1 with the entire set.
Comment 1 Jean-François Fortin Tam 2011-02-28 12:40:03 EST
The keyboard layout is available inside /usr/share/X11/xkb/symbols/ca
Bug 556159 (spanish dvorak) highlights three steps:

1. file a bug against kbd: Bug 680989
2. file a bug against system-config-keyboard: Bug 680990
3. file a bug against anaconda (this current bug report).
Comment 2 Lionel Dricot 2012-01-04 10:05:01 EST
This bug could be generalized to "cannot install with most keyboard layouts available in X.org".

I still miss any reasoning on why some layout are available during installations and some others not.
Comment 3 Jens Petersen 2012-03-05 00:38:59 EST
I am assuming this is still true for current Fedora releases?
Comment 4 Lionel Dricot 2012-03-05 01:49:36 EST
Didn't try F17alpha but still the case for F16, yes.
Comment 5 Nicolas Mailhot 2012-03-12 10:23:21 EDT
(In reply to comment #3)
> I am assuming this is still true for current Fedora releases?

Basically, Debian has a nice system where xkb-config layouts (used by xorg) are dynamically transformed into console layouts, while Fedora uses two different layout databases, which are not synced

No one really updates kbd layouts anymore, since it's obvious to layout authors the Debian solution is the right solution, and once Ubuntu inherited it from Debian it was game over for other distributions and time to play catch-up if they wanted to care about i18n and desktop.

The problem has been known for years and the number of people affected has only grown with time and kbd abandonment. And yes I realise Debian's dynamic mapping is harder to code than using a static xkb-config/kbd table, or dumping this table and only supporting the layouts that appear under the same name in both systems, but the other solutions only work if layout authors bother to write two layouts (one for xkb-config and one for kbd) each time they do a change, and they've voted with their feet a long time ago (and additionally even when one did this it took months to get add a new line in the mapping table used by anaconda – great way to make people not bother)

And I've not seen any of the people advocating against the Debian solution volunteer to write all the kbd tables the alternative required either.
Comment 6 Máirín Duffy 2012-06-05 11:53:08 EDT
*** Bug 712877 has been marked as a duplicate of this bug. ***
Comment 7 Máirín Duffy 2012-06-05 12:20:10 EDT
This is planned to be fixed in the anaconda redesign.
Comment 8 Chris Lumens 2012-08-03 15:27:36 EDT
This should be fixed in the new ui included with anaconda-18.3.