Bug 668157

Summary: gnome-session should not depend on polkit-gnome
Product: [Fedora] Fedora Reporter: Christoph Wickert <cwickert>
Component: gnome-sessionAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: jmccann, rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-05 23:30:21 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 661442, 657006    

Description Christoph Wickert 2011-01-08 09:15:21 EST
Description of problem:
gnome-session should not depend on polkit-gnome but rather use the virtual provides "PolicyKit-authentication-agent". We cannot and should not hardcode a certain authentication-agent, otherwise we trigger problems as in bug 657006.

Version-Release number of selected component (if applicable):
gnome-session-2.32.0-1.fc14.x86_64

Additional info:
This bug is not only about the bug 657006 but also because of the ongoing FESCo effort to get rid or dependency chain painpoints, see https://fedorahosted.org/fesco/ticket/345
Comment 1 Christoph Wickert 2011-03-05 23:30:21 EST
After reading http://lists.fedoraproject.org/pipermail/devel-announce/2011-February/000758.html and the following discussion I doubt there is the slightest change for this change, so I'm going to close the bug myself.