Bug 668157 - gnome-session should not depend on polkit-gnome
Summary: gnome-session should not depend on polkit-gnome
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 657006 depchain
TreeView+ depends on / blocked
 
Reported: 2011-01-08 14:15 UTC by Christoph Wickert
Modified: 2011-03-06 04:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-06 04:30:21 UTC
Type: ---


Attachments (Terms of Use)

Description Christoph Wickert 2011-01-08 14:15:21 UTC
Description of problem:
gnome-session should not depend on polkit-gnome but rather use the virtual provides "PolicyKit-authentication-agent". We cannot and should not hardcode a certain authentication-agent, otherwise we trigger problems as in bug 657006.

Version-Release number of selected component (if applicable):
gnome-session-2.32.0-1.fc14.x86_64

Additional info:
This bug is not only about the bug 657006 but also because of the ongoing FESCo effort to get rid or dependency chain painpoints, see https://fedorahosted.org/fesco/ticket/345

Comment 1 Christoph Wickert 2011-03-06 04:30:21 UTC
After reading http://lists.fedoraproject.org/pipermail/devel-announce/2011-February/000758.html and the following discussion I doubt there is the slightest change for this change, so I'm going to close the bug myself.


Note You need to log in before you can comment on or make changes to this bug.