Bug 669692

Summary: Size of tabs get smaller and smaller; tabs don't keep their size
Product: [Fedora] Fedora Reporter: Horst H. von Brand <vonbrand>
Component: gnome-terminalAssignee: Bastien Nocera <bnocera>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: alevy, behdad, bnocera, dr.diesel, rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-16 17:52:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Horst H. von Brand 2011-01-14 08:01:11 EST
Description of problem:
I opened a gnome-terminal and some 8 tabs in it, when I opened the last tab their size was something like 70x14 (not 80x24). Resizing each individual tab to its 80x24 size doesn't help (much), other (already resized) tabs shrink when I do that.

Version-Release number of selected component (if applicable):

How reproducible:
Tried with two  gnome-terminals, same results

Steps to Reproduce:
1. Open several tabs in a gnome-terminal
Actual results:
Tiny tabs

Expected results:
Normal size tabs

Additional info:
Comment 1 Alon Levy 2011-01-15 13:16:35 EST
I have the same problem. I can add more information:

this happens every time you switch focus for a tab. So in Horst's example because he opened extra tabs each open caused a focus change. But if you continue to switch tabs, doesn't matter how - keyboard shortcut, clicking the tab title, they reduce in size. I think the reduction is by 1 row and 1 column (even though it doesn't fit with Horst's example above).

It isn't related to the window manager (happens without a window manager running in fact)

doesn't happen if gnome-terminal is maximized.

doesn't happen if you have a single tab (ok, not very enlightening).
Comment 2 Alon Levy 2011-01-16 17:59:15 EST
This no longer happens with version 2.33.4 of gnome-terminal.
Comment 3 Horst H. von Brand 2011-01-18 09:37:33 EST
gnome-terminal-2.33.4-2.fc15.x86_64 under xfce4-4.8.0-1.fc15 here. It does still happen.
Comment 4 Horst H. von Brand 2011-01-21 11:29:24 EST
Now running:


gnome-terminals work fine here.
Comment 5 Andy Lawrence 2011-01-29 17:59:44 EST
Horst, are you saying this bug can be completed?
Comment 6 Horst H. von Brand 2011-02-23 21:37:31 EST
(In reply to comment #5)
> Horst, are you saying this bug can be completed?

Sorry, Gnome is completely dead for me right now.

Running gnome-terminal under XFCE gives all sort of resizing weirdness

Start: 80x24 ~~-> 32x24, click on lower frame ~~-> 31x2

Comment 7 Horst H. von Brand 2011-03-12 20:17:15 EST
Just tried in 15 alpha on x86_64, updated for today. I installed Gnome, XFCE and LXDE. For some strange reason, Terminal (XFCE) shows up twice in the menu. Terminal works fine under Gnome shell, gnome-terminal started from a Terminal shows the weirdness noted in comment 6.

Comment 8 Horst H. von Brand 2011-03-16 17:52:39 EDT
This is the same as the other bug I reported for this.

*** This bug has been marked as a duplicate of bug 679986 ***
Comment 9 Horst H. von Brand 2011-03-16 17:54:22 EDT
Got the bug number wrong, sorry :-(

*** This bug has been marked as a duplicate of bug 670173 ***