Bug 679986 - During SELinux autorelabel it tries to run Syslog Kernel Log Buffer Bridge
During SELinux autorelabel it tries to run Syslog Kernel Log Buffer Bridge
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 21:15 EST by Horst H. von Brand
Modified: 2011-04-01 22:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-01 22:22:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2011-02-23 21:15:51 EST
Description of problem:
I had to relabel for SELinux by creating /.autorelabel and rebooting. During the relabeling process the message "Starting systemd Syslog Kernel Log Buffer Bridge" repeated at least a dozen times. I assumed thad during relabeling nothing else should run? And why repeat the same message a lot?

Version-Release number of selected component (if applicable):
systemd-18-1.fc16.x86_64
policycoreutils-2.0.85-12.fc15.x86_64

How reproducible:
No idea, happened once

Steps to Reproduce:
1. Create /.autorelabel, reboot
2.
3.
  
Actual results:
Lots of "Starting ..." messages during relabeling

Expected results:
There should be minimal activity during relabeling.

Additional info:
Comment 1 Lennart Poettering 2011-02-24 10:10:15 EST
That's a tiny bridge that connects /dev/log to kmsg. It is only started when some process writes something to /dev/log, and then terminates itself automatically after 10s (as a side note: I inreased that to 5min in systemd git).

So, this is not really systemd's fault: something is writing messages to /dev/log. And we shouldn't make systemd ignore that but figure out what exactly is responsible for that.

Any chance you could try to reproduce this issue but boot with plymouth completely off ("rd_NO_PLYMOUTH" on the kernel cmdline) and with debug output of the kernel on? ("debug" on the kernel cmdline). Then, the messages written to /dev/log should reach the console via kmsg, and we should be able to figure out what is going on.
Comment 2 Horst H. von Brand 2011-03-16 17:52:39 EDT
*** Bug 669692 has been marked as a duplicate of this bug. ***
Comment 3 Horst H. von Brand 2011-04-01 19:40:34 EDT
This has been fixed (just had to relabel because of /run, no trouble whatsoever). Can't say which of the hundreds of updates did the trick :-(
Comment 4 Lennart Poettering 2011-04-01 22:22:57 EDT
OK, thanks. Closing then.

Note You need to log in before you can comment on or make changes to this bug.