This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 673753

Summary: [Virt-Manager] Translation Update for RHEL 6.1
Product: Red Hat Enterprise Linux 6 Reporter: A S Alam <aalam>
Component: virt-managerAssignee: Cole Robinson <crobinso>
Status: CLOSED DEFERRED QA Contact: QE Internationalization Bugs <qe-i18n-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.1CC: dallan, eng-l10n-bugs, ktakemur, mjenner, mshao, mzhan, syeghiay, xen-maint
Target Milestone: rcKeywords: Translation
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-27 11:14:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
authorization dialog
none
Detail for virtual Host
none
Screenshot of Dialog - Translation
none
Creation of vm - Translation
none
vm creation Window - Translation none

Description A S Alam 2011-01-30 06:41:16 EST
Description of problem:
Bug for Translation issue with virt-manager. One Translation bug for RHEL6.1 release.

Screen-shots are attached for Reference.

Status:
French (fr) 	90% (920/72/24)
	
Japanese (ja) 	90% (919/71/26)
	
Panjabi (Punjabi) (pa) 	90% (919/71/26)
	
Spanish (es) 	90% (920/71/25)
	
Bengali (India) (bn_IN) 	86% (876/101/39)
	
Gujarati (gu)  86% (876/101/39)
	
Kannada (kn) 	86% (877/100/39)
	
Korean (ko) 	86% (876/101/39)
	
Malayalam (ml) 	86% (876/101/39)
	
Marathi (mr) 	86% (876/101/39)
	
Oriya (or) 	86% (876/101/39)
	
Russian (ru) 	86% (876/101/39)
	
Telugu (te) 	86% (876/101/39)
	
German (de) 	85% (871/101/44)
	
Chinese (China) (zh_CN) 	74% (756/198/62)
	
Italian (it) 	73% (749/202/65)
	
Tamil (ta) 	73% (742/202/72)
	
Hindi (hi) 	72% (741/202/73)
	
Assamese (as) 	69% (711/201/104)

Chinese (Taiwan) (zh_TW) 	29% (300/474/242)


Version-Release number of selected component (if applicable):
virt-manager-0.8.6-1.el6.noarch

How reproducible:


Steps to Reproduce:
1. run virt-manager in above listed language
2.
3.
  
Actual results:
Many messages are in English

Expected results:
Need to be translated

Additional info:
Upstream Link: https://translate.fedoraproject.org/projects/p/virt-manager/c/default/
Comment 1 A S Alam 2011-01-30 06:42:38 EST
Created attachment 476011 [details]
authorization dialog
Comment 2 A S Alam 2011-01-30 06:43:24 EST
Created attachment 476012 [details]
Detail for virtual Host
Comment 3 A S Alam 2011-01-30 06:44:11 EST
Created attachment 476013 [details]
Screenshot of Dialog - Translation
Comment 4 A S Alam 2011-01-30 06:44:59 EST
Created attachment 476014 [details]
Creation of vm - Translation
Comment 5 A S Alam 2011-01-30 06:46:01 EST
Created attachment 476015 [details]
vm creation Window - Translation
Comment 7 Ankit Patel 2011-01-31 01:51:07 EST
Translations missing because of the recent rebase (0.8.6-1), otherwise virt-manager was completely translated after 0.8.4-5 that we fixed via bug 575681.

Now, will need to provide another patch to update rebased virt-manager.

Thanks for reporting the bug!
Ankit
Comment 8 Ankit Patel 2011-02-01 02:12:25 EST
@crobinso,

1. Would you like to receive translations directly in the upstream repo? https://translate.fedoraproject.org/projects/p/virt-manager/c/default/

2. By which date you expect this translations?

Thanks!
Ankit
Comment 9 Cole Robinson 2011-02-02 19:56:39 EST
*** Bug 634049 has been marked as a duplicate of this bug. ***
Comment 10 Cole Robinson 2011-02-02 20:11:09 EST
1) Yes, translations via the fedora translation system is preferable I think. That way we can be sure any changes apply to future versions as best as possible. Sorry that I did not incorporate your 6.0 changes against upstream...

2) Not sure what the final date for this is. String freeze is March 10th, so anytime after that should be fine I think.
Comment 11 Ankit Patel 2011-02-07 03:45:36 EST
Alright, thx.
Comment 13 Cole Robinson 2011-03-31 10:59:22 EDT
Since I haven't heard anything yet and it's getting late in the 6.1 cycle, moving to 6.2.

Since it is likely we will rebase in 6.2, getting translations as close to 100% upstream is probably the best thing to do, that way the rebase will basically close this bug.
Comment 14 Cole Robinson 2011-09-27 11:14:50 EDT
I'm closing this for RHEL. I think best solution for translations is to just have our translators contribute to virt-manager in transifex upstream, then new releases will already have near total string coverage.

If I'm way off base please reopen, but since this bug has limped along for a months now I don't see that it's worth tracking.