Bug 679885

Summary: mock fails to build packages for EPEL 6
Product: [Fedora] Fedora Reporter: Benjamin Gilbert <bgilbert>
Component: mockAssignee: Clark Williams <williams>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 14CC: antti.andreimann, cassmodiah, d.bz-redhat, dcantrell, gholms, herrold, madko, mebrown, number.cruncher, redhat-bugzilla, sergio.pasra, ss, williams
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: mock-1.0.19-1.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-09 01:27:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
/etc/mock/sl-6-i386.cfg none

Description Benjamin Gilbert 2011-02-23 19:07:35 UTC
Description of problem:
The mock chroot configs for EPEL 6 enable the "beta" repo, which no longer has any active mirrors, so EPEL 6 package builds fail.

Version-Release number of selected component (if applicable):
mock-1.1.9-1.fc14

How reproducible:
Always

Steps to Reproduce:
1. mock -r epel-6-i386 something.src.rpm
  
Actual results:
ERROR: Command failed: 
 # /usr/bin/yum --installroot /var/lib/mock/epel-6-i386/root/  groupinstall buildsys-build
Error: Cannot retrieve repository metadata (repomd.xml) for repository: beta. Please verify its path and try again

Expected results:
Package builds.

Comment 1 Simon 2011-03-07 09:14:59 UTC
Created attachment 482631 [details]
/etc/mock/sl-6-i386.cfg

Dear Benjamin,

the problem is that the epel 6 configuration files of mock will use centos 6 repositories, which are currently disabled because centos 6 doesn't exist.

Scientific Linux is released a few days ago. I built my package in mock with sl in the config-file since sl6 beta released. I attached my /etc/mock/sl-6-i386.cfg to this bug.

Feel free to use it

Regards
Simon

Comment 2 Fedora Admin XMLRPC Client 2011-03-11 18:10:08 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Benjamin Gilbert 2011-06-24 18:59:01 UTC
Bug is still present in 1.1.10-1.fc14, with the same result.  Clark, how can this WORKFORYOU when the chroot config points to a nonexistent repo?

I have been successfully using Scientific Linux for EPEL builds on my own system.  Why not update the official mock configs to point to SL instead of CentOS?

Comment 4 Clark Williams 2011-06-24 20:49:16 UTC
Grrr. Apologies, I completely forgot that my regression test suite filtered out epel-6 from test consideration. 

I don't think that I can unilaterally declare that we use SL rather than CentOS. I think we would need to bring it up to the Fedora Board before we made that sort of decision.

Comment 5 Sergio Pascual 2011-07-15 16:08:07 UTC
mock-1.1.11 doesn't build packages for el6 out of the box, although CentOS 6
has been released and the its repositories are available.

Comment 6 Sergio Pascual 2011-07-15 16:08:27 UTC
*** Bug 722533 has been marked as a duplicate of this bug. ***

Comment 7 Simon 2011-07-16 09:48:08 UTC
@Sergio - As far as i known is the fraternization with the CentOS Project more important than a working epel6 branch for mock.

Comment 8 Sergio Pascual 2011-07-16 14:23:03 UTC
(In reply to comment #7)
> @Sergio - As far as i known is the fraternization with the CentOS Project more
> important than a working epel6 branch for mock.

I understand that, but the CentOS 6 has been released and the configuration files are still broken. There is a beta repository that doesn't exist

ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-6-x86_64/root/', 'groupinstall', 'buildsys-build', '--setopt=tsflags=nocontexts']
Ignored option -c (probably due to merging -yc != -y -c)
Error: Cannot retrieve repository metadata (repomd.xml) for repository: beta. Please verify its path and try again

and if I remove this repository from epel-6-x86_64.cfg I still get

ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-6-x86_64/root/', 'groupinstall', 'buildsys-build', '--setopt=tsflags=nocontexts']
Ignored option -c (probably due to merging -yc != -y -c)
Error: Package: epel-release-6-5.noarch (epel)
           Requires: /bin/sh
 You could try using --skip-broken to work around the problem
Error: Package: epel-release-6-5.noarch (epel)
           Requires: redhat-release >= 6
 You could try running: rpm -Va --nofiles --nodigest


when building.

Comment 9 Clark Williams 2011-07-16 15:45:52 UTC
It would have been nice to know that the CentOS 6 repos were going live before they actually did. Sigh...

Has anyone removed the [beta] stanzas in the epel-6-* config files and seen if they build using the newly release mirrors?

Comment 10 Sergio Pascual 2011-07-16 20:53:57 UTC
That's what you get in that case

ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-6-x86_64/root/',
'groupinstall', 'buildsys-build', '--setopt=tsflags=nocontexts']
Ignored option -c (probably due to merging -yc != -y -c)
Error: Package: epel-release-6-5.noarch (epel)
           Requires: /bin/sh
 You could try using --skip-broken to work around the problem
Error: Package: epel-release-6-5.noarch (epel)
           Requires: redhat-release >= 6
 You could try running: rpm -Va --nofiles --nodigest

Comment 11 Clark Williams 2011-07-17 14:32:18 UTC
I'm at a loss as to what's going wrong after removing the beta stanza's. The mirror list lines *look* right and obviously they start the process of fetching packages.

Either the epel-release package has something wacky with it, or there's some magic missing in the epel-6-* configs for the repos.

Comment 12 Jack Perdue 2011-07-23 15:28:21 UTC
Try enabling the centos repos???

$ grep -A2 -e '\[base\]' -e '\[updates\]' /etc/mock/epel-6-x86_64.cfg 
[base]
name=BaseOS
enabled=0
--
[updates]
name=updates
enabled=0

Once I enabled them here, it seems happier, so the fix would seem to be.

for each epel-6 file in /etc/mock ; do
   add enabled=0 for repos beta and beta-optional
   change enabled from =0 to =1 for repos base and update
done

(tested with mock-1.1.10-1.fc14.noarch)

Comment 13 Simon 2011-07-26 14:28:35 UTC
I think this relates to https://bugzilla.redhat.com/show_bug.cgi?id=719740

Comment 14 Simon 2011-07-26 16:12:21 UTC
(In reply to comment #12)
> T
> Once I enabled them here, it seems happier, so the fix would seem to be.
> 
> for each epel-6 file in /etc/mock ; do
>    add enabled=0 for repos beta and beta-optional
>    change enabled from =0 to =1 for repos base and update
> done
> 
> (tested with mock-1.1.10-1.fc14.noarch)

Agreed; works. Tested here on F14 also.

Comment 15 Fedora Update System 2011-07-26 21:28:45 UTC
mock-1.1.12-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.12-1.el6

Comment 16 Fedora Update System 2011-07-26 21:29:05 UTC
mock-1.1.12-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mock-1.1.12-1.fc14

Comment 17 Fedora Update System 2011-07-26 21:29:23 UTC
mock-1.0.19-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.19-1.el5

Comment 18 Fedora Update System 2011-07-26 21:29:41 UTC
mock-1.1.12-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mock-1.1.12-1.fc15

Comment 19 Fedora Update System 2011-07-30 10:38:04 UTC
Package mock-1.1.12-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.1.12-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mock-1.1.12-1.el6
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2011-08-09 01:27:23 UTC
mock-1.1.12-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2011-08-09 01:32:49 UTC
mock-1.1.12-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2011-08-16 21:01:40 UTC
mock-1.1.12-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2011-08-16 21:02:44 UTC
mock-1.0.19-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.