Bug 722533 - Build for el6 still broken, CentOS 6 has been released
Summary: Build for el6 still broken, CentOS 6 has been released
Keywords:
Status: CLOSED DUPLICATE of bug 679885
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Clark Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-15 15:28 UTC by Sergio Pascual
Modified: 2011-07-16 14:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-15 16:08:27 UTC
Type: ---


Attachments (Terms of Use)

Description Sergio Pascual 2011-07-15 15:28:44 UTC
mock-1.1.11 doesn't build packages for el6 out of the box, although CentOS 6 has been released and the its repositories are available

Comment 1 Sergio Pascual 2011-07-15 16:08:27 UTC

*** This bug has been marked as a duplicate of bug 679885 ***

Comment 2 R P Herrold 2011-07-16 10:00:40 UTC
Sergio

What problem are you having with the released CentOS 6 archive?  The assertion of an inability to build, without a reproducer makes it hard to analyze this bug

-- Russ herrold

Comment 3 Sergio Pascual 2011-07-16 14:20:21 UTC
Building a package for el6:

$ mock -r -r epel-6-x86_64 somepackage.src.rpm
(snip)
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-6-x86_64/root/', 'groupinstall', 'buildsys-build', '--setopt=tsflags=nocontexts']
Ignored option -c (probably due to merging -yc != -y -c)
Error: Cannot retrieve repository metadata (repomd.xml) for repository: beta. Please verify its path and try again

The configuration file for epel-6 still has some mentions to a "beta" repository.
If you remove them, the build still fails with:

ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-6-x86_64/root/', 'groupinstall', 'buildsys-build', '--setopt=tsflags=nocontexts']
Ignored option -c (probably due to merging -yc != -y -c)
Error: Package: epel-release-6-5.noarch (epel)
           Requires: /bin/sh
 You could try using --skip-broken to work around the problem
Error: Package: epel-release-6-5.noarch (epel)
           Requires: redhat-release >= 6
 You could try running: rpm -Va --nofiles --nodigest


Note You need to log in before you can comment on or make changes to this bug.