Due to a recent update on Javascript code a full page refresh on your browser might be needed.

Bug 682859

Summary: /sbin/mkdumprd uses nash to build initramfs but it's no more available
Product: [Fedora] Fedora Reporter: Giacomo Montagner <gmontagner>
Component: kexec-toolsAssignee: Neil Horman <nhorman>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 14CC: caiqian, dshaw, nhorman
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: kexec-tools-2.0.0-40.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-28 19:20:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Giacomo Montagner 2011-03-07 19:44:33 UTC
Description of problem:

It seems related to bug 572569: /sbin/mkdumprd tries to use nash to build 
initramfs, but nash is no longer available. 

# service kdump restart
Stopping kdump:                                            [  OK  ]
Detected /etc/kdump.conf or /boot/vmlinuz-2.6.35.11-83.fc14.x86_64 change
Rebuilding /boot/initrd-2.6.35.11-83.fc14.x86_64kdump.img
WARNING: using /root for temporary files
/sbin/mkdumprd: line 951: nash: command not found
Starting kdump:                                            [  OK  ]


Version-Release number of selected component (if applicable):
kexec-tools-2.0.0-39.fc14.1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Make a change to /etc/kdump.conf to trigger a rebuild of initramfs
2. service kdump restart
  
Actual results:
Apparently initrd for crash kernel is generated, but I cannot tell 
if it might fail with some dm configuration. According to comment on 
line 1477 of /sbin/mkdumprd: 
# nash should do lvm probing for us and write its own configs.

I suppose this fails, at least. 

Expected results:
No warnings (and no use of nash into the script).

Comment 1 Neil Horman 2011-03-07 19:55:36 UTC
yeah, it should work just fine, that whole emitdms function that spawns that error no longer needs to be there, and does nothing.  I'll remove it from f14 and rawhide shortly.

Comment 2 Fedora Update System 2011-03-10 20:07:10 UTC
kexec-tools-2.0.0-40.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kexec-tools-2.0.0-40.fc14

Comment 3 Neil Horman 2011-03-28 14:57:37 UTC
*** Bug 690661 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2011-03-28 19:20:14 UTC
kexec-tools-2.0.0-40.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.