Bug 690661 - /sbin/kpartx not found when building kdump ramdisk
Summary: /sbin/kpartx not found when building kdump ramdisk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kexec-tools
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-25 00:04 UTC by David Shaw
Modified: 2011-07-13 19:27 UTC (History)
2 users (show)

Fixed In Version: kexec-tools-2.0.0-41.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-13 19:27:12 UTC
Type: ---


Attachments (Terms of Use)

Description David Shaw 2011-03-25 00:04:31 UTC
Description of problem:

When starting kdump, it automatically (re)builds the appropriate initrd when necessary.  However, this displays:

   cp: cannot stat `/sbin/kpartx': No such file or directory

Version-Release number of selected component (if applicable):

kexec-tools-2.0.0-39.fc14.1.x86_64

How reproducible:

Every time the dump initrd is rebuilt.

Steps to Reproduce:
1. Install kexec-tools
2. service kdump start
  
Actual results:

Error message from cp

Expected results:

No error message

Additional info:

I'm not sure why the dump initrd wants kpartx, but it seems to work just fine without it, at least in my particular setup (/boot on a partition, everything else in LVM).

The obvious workaround is to just install kpartx, but if the dump initrd actually needs it, then shouldn't the kexec-tools RPM depend on it?

Comment 1 Neil Horman 2011-03-28 14:57:37 UTC
This is fixed in kexec-tools-2.0.0-40 as part of bz 682859

*** This bug has been marked as a duplicate of bug 682859 ***

Comment 2 David Shaw 2011-04-04 14:31:19 UTC
I just tested kexec-tools-2.0.0-40.fc14.x86_64 and it unfortunately does not resolve the issue:

# rpm -q kexec-tools
kexec-tools-2.0.0-40.fc14.x86_64
# rm -f /boot/initrd-2.6.35.11-83.fc14.x86_64kdump.img 
# service kdump start
No kdump initial ramdisk found.                            [WARNING]
Rebuilding /boot/initrd-2.6.35.11-83.fc14.x86_64kdump.img
cp: cannot stat `/sbin/kpartx': No such file or directory

(I'm not sure if I should reopen this bug or bug 682859, which this was duped to)

Comment 3 Neil Horman 2011-04-04 16:12:05 UTC
Sorry, sillyness on my part.  kpartx's usage is gone in f14, but we still try to include the binary.  I've fixed this in -41

Comment 4 Fedora Update System 2011-04-04 16:52:48 UTC
kexec-tools-2.0.0-41.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kexec-tools-2.0.0-41.fc14

Comment 5 Fedora Update System 2011-04-05 05:19:06 UTC
Package kexec-tools-2.0.0-41.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kexec-tools-2.0.0-41.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kexec-tools-2.0.0-41.fc14
then log in and leave karma (feedback).

Comment 6 David Shaw 2011-07-12 19:30:25 UTC
This does seem to fix the issue (and I've left karma).  Any update on getting it pushed to stable?   Thanks.

Comment 7 Neil Horman 2011-07-13 13:22:10 UTC
Done, it should be puhsed to stable in the next day or so.  Thanks!

Comment 8 Fedora Update System 2011-07-13 19:27:07 UTC
kexec-tools-2.0.0-41.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.