This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours

Bug 689825

Summary: [NV4b] NVidia 7600GS (G73) card stopped working, X does not start
Product: [Fedora] Fedora Reporter: Cristian Ciupitu <cristian.ciupitu>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 15CC: airlied, ajax, bskeggs, gansalmon, itamar, jonathan, kernel-maint, lists.kho, madhu.chinakonda, sdodson
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-2.6.38.3-18.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-26 22:39:24 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Screenshot: no X
none
/var/log/messages
none
Screenshot: no X (2)
none
dmesg (2)
none
/var/log/messages (2)
none
Xorg.0.log (2)
none
dmesg (3)
none
Xorg.0.log (3)
none
/var/log/messages (3) none

Description Cristian Ciupitu 2011-03-22 10:47:29 EDT
Created attachment 486808 [details]
Screenshot: no X

Description of problem:
My system has an NVidia 7600GS (G73) video card and X does not start when using the kernel mentioned bellow.

Version-Release number of selected component (if applicable):
kernel-2.6.38-1.fc15.x86_64.rpm
xorg-x11-drv-nouveau-0.0.16-23.20110303git92db2bc.fc15.x86_64.rpm
xorg-x11-server-Xorg-1.10.0-3.fc15.x86_64.rpm

How reproducible:
Every time

Steps to Reproduce:
1. Boot kernel-2.6.38-0.rc5.git1.1.fc15.x86_64 in "graphical.target" (runlevel 5)
  
Actual results:
X does not start. See attached screenshot. The messages seem to be from the previous (re)boot possibly with the older kernel.

Expected results:
X should start.

Additional info:
X starts when using kernel-2.6.38-0.rc5.git1.1.fc15.x86_64.rpm, although it still doesn't work too well. If I start a program, e.g. firefox or gnome-terminal its window will start to flicker. It will appear and disappear rapidly forever.

lspci output for video card:
01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Giga-byte Technology Device 341a
	Flags: bus master, fast devsel, latency 0, IRQ 11
	Memory at e1000000 (32-bit, non-prefetchable)
	Memory at d0000000 (64-bit, prefetchable)
	Memory at e0000000 (64-bit, non-prefetchable)
	I/O ports at 2000
	Capabilities: [60] Power Management version 2
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00

The /var/log/Xorg.* files seem to old to be from this failed boot, so I won't attach them.
Comment 1 Cristian Ciupitu 2011-03-22 10:49:03 EDT
Created attachment 486809 [details]
/var/log/messages

It contains messages from both kernels.
Comment 2 Matěj Cepl 2011-03-25 06:14:58 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log), and
* output of the dmesg command

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Cristian Ciupitu 2011-03-25 08:30:12 EDT
I've tried again with the following packages:
kernel-2.6.38.1-6.fc15.x86_64
xorg-x11-drv-nouveau-0.0.16-24.20110324git8378443.fc15.x86_64

This time the screen was full of artifacts (see attachment).

Kernel command line:
ro root=UUID=e6fa0860-9915-4
b1d-b5e0-2eed2e993c8b rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SY
SFONT=latarcyrheb-sun16 KEYTABLE=us drm.debug=0x04
Comment 4 Cristian Ciupitu 2011-03-25 08:31:39 EDT
Created attachment 487549 [details]
Screenshot: no X (2)

Lots of artifacts.
Comment 5 Cristian Ciupitu 2011-03-25 08:33:29 EDT
Created attachment 487550 [details]
dmesg (2)
Comment 6 Cristian Ciupitu 2011-03-25 08:34:46 EDT
Created attachment 487551 [details]
/var/log/messages (2)
Comment 7 Cristian Ciupitu 2011-03-25 08:35:16 EDT
Created attachment 487552 [details]
Xorg.0.log (2)
Comment 8 Cristian Ciupitu 2011-03-29 15:39:27 EDT
I've retested with kernel-2.6.38.2-8.fc15.x86_64 and I had mixed results. My memory isn't helping me, so please take the following with a grain of salt.

First boot in _text mode_ (multi-user.target) didn't work at all and the screen had only artifacts which by the way made the LCD screen buzz. Then I booted kernel-2.6.38.1-6.fc15.x86_64, kernel-2.6.38-1.fc15.x86_64 and kernel-2.6.38-0.rc5.git1.1.fc15.x86_64 and none of them worked. The system was not even responding to ping requests. I booted kernel-2.6.38-0.rc5.git1.1.fc15.x86_64 _with nomodeset_ and it worked. Then I tried _without nomodeset_ in GUI mode (graphical.target) and it kind of worked, meaning that I had that flickering issue again.

Finally, I rebooted and started kernel-2.6.38.2-8.fc15.x86_64. The background of Fedora 15 appeared nicely on the screen, but that was it. I had no user list or anything else. I was able to connect to the system via SSH, so I was able to collect the information requested by Matej Cepl. N.B.: The logs contain information from all kernels.

If you happen to have any wild or crazy ideas please mention them, because I'll remove the drive with Fedora 15 in a couple of days and afterwards I might not have enough space for testing Fedora 15.
Comment 9 Cristian Ciupitu 2011-03-29 15:40:42 EDT
Created attachment 488543 [details]
dmesg (3)
Comment 10 Cristian Ciupitu 2011-03-29 15:41:06 EDT
Created attachment 488544 [details]
Xorg.0.log (3)
Comment 11 Cristian Ciupitu 2011-03-29 15:43:47 EDT
Created attachment 488546 [details]
/var/log/messages (3)

Contains messages from kernel-2.6.38-0.rc5.git1.1.fc15.x86_64, kernel-2.6.38-1.fc15.x86_64, kernel-2.6.38.1-6.fc15.x86_64, kernel-2.6.38.2-8.fc15.x86_64.
Comment 12 Ben Skeggs 2011-03-29 16:56:36 EDT
Is this a regression from something?  Has the card worked previously?
Comment 13 Cristian Ciupitu 2011-03-29 18:29:28 EDT
With the exception of bug #550720 it worked fine in Fedora 14, but please take note that I use the nvidia driver most of the time because of that bug.
Comment 14 Martin Kho 2011-04-03 10:52:23 EDT
Hi,

I have exact the same video-card. My system totally locks up with KDE_fc-15_beta_tc1 from 2011, April, 1. It looks to be an issue with the kernel part (drm) of the video driver, because I'm using rawhide (fc16) without a problem. Better openGL is working like a charm :-) The nouveau driver is in fc15 and rawhide the same, the kernels (and xorg-server) are different:

fc15_beta_tc1:
xorg-x11-drv-nouveau-0.0.16-24.20110324git8378443.fc15.x86_64
kernel-2.6.38.2-8.fc15.x86_64

fc16:
xorg-x11-drv-nouveau-0.0.16-24.20110324git8378443.fc16.x86_64
kernel-2.6.39-0.rc0.git11.0.fc16.x86_64
btw: the following kernels were also working ok:
kernel-2.6.38-0.rc7.git2.3.fc16.x86_64
kernel-2.6.38-0.rc6.git0.1.fc16.x86_64

Hope this helps and thanks,

Martin Kho

@Ben I hope you can solve this issue before fc15 gets Gold, because I don't like to use the propriety blob :-)
Comment 15 Cristian Ciupitu 2011-04-05 14:20:47 EDT
martin is right, it does work in Fedora rawhide with those packages, but on the other hand I don't have any 3D acceleration, so I can't run the full GNOME3 shell. I can't even run glxgears:
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
Comment 16 Ben Skeggs 2011-04-06 22:45:55 EDT
Okay, I believe I've identified the issue here.  There's a kernel building now that will hopefully fix the problem:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2980838
Comment 17 Cristian Ciupitu 2011-04-07 08:16:14 EDT
I've retested with kernel-2.6.38.2-12.fc15.x86_64.rpm and X is working again. I have even played OpenArena in 1920x1200 (by the way the brightness setting doesn't seem to work) and Teeworlds.

Unfortunately suspend still doesn't work too well, but that's another issue. The bug can be closed when the fix hits the official repositories.
Comment 18 Ben Skeggs 2011-04-07 19:27:41 EDT
*** Bug 693133 has been marked as a duplicate of this bug. ***
Comment 19 Fedora Update System 2011-04-22 11:56:01 EDT
kernel-2.6.38.3-18.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.3-18.fc15
Comment 20 Fedora Update System 2011-04-22 21:15:00 EDT
Package kernel-2.6.38.3-18.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.38.3-18.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.38.3-18.fc15
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2011-04-26 22:39:08 EDT
kernel-2.6.38.3-18.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.