This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 693133 - Graphics corruption and X is unusable on G71 7950GT with nouveau
Graphics corruption and X is unusable on G71 7950GT with nouveau
Status: CLOSED DUPLICATE of bug 689825
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-02 18:15 EDT by Scott Dodson
Modified: 2011-04-07 19:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-07 19:27:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg booting runlevel 3 w/o rhgb and quiet options (124.50 KB, text/plain)
2011-04-02 18:15 EDT, Scott Dodson
no flags Details
Xorg.log (30.87 KB, application/octet-stream)
2011-04-02 18:15 EDT, Scott Dodson
no flags Details

  None (edit)
Description Scott Dodson 2011-04-02 18:15:07 EDT
Created attachment 489618 [details]
dmesg booting runlevel 3 w/o rhgb and quiet options

Description of problem:
As soon as X starts my computer locks up. If I boot to run level 3 I see considerably graphics corruption in the console and a lot of the following error messages.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.16-24.20110324git8378443.fc15.x86_64
kernel-2.6.38.2-9.fc15.x86_64

I have also tried the Fedora-15-Nightly-20110401.17-x86_64 live cd

How reproducible:
100% has been happening for a week or so.

Steps to Reproduce:
1. Boot normally without nomodeset option
2. If booting to runlevel 3 you will experience corruption but it will boot. If booting to runlevel 5 it locks the system up as soon as it enters runlevel 5.

  
Actual results:
Machine locks up, graphics corruption.

Expected results:
Working machine

Additional info:
http://www.smolts.org/client/show/pub_6fa23ecb-a0ba-4f2f-a914-ec563031502b

When booting without rhgb and quiet options to runlevel 3 I experience :
[   36.127155] [drm] nouveau 0000:01:00.0: PFIFO_DMA_PUSHER - Ch 0 Get 0x00011000 Put 0x00001114 State 0x80000000 (err: INVALID_CMD) Push 0x00000000
[   36.127473] [drm] nouveau 0000:01:00.0: PFIFO_DMA_PUSHER - Ch 0 Get 0x00011000 Put 0x0000129c State 0x80000000 (err: INVALID_CMD) Push 0x00000000

dmesg and Xorg log attached
Comment 1 Scott Dodson 2011-04-02 18:15:44 EDT
Created attachment 489619 [details]
Xorg.log
Comment 2 Ben Skeggs 2011-04-07 19:27:41 EDT
kernel-2.6.38.2-12.fc15 should fix this issue.

*** This bug has been marked as a duplicate of bug 689825 ***

Note You need to log in before you can comment on or make changes to this bug.