Bug 691410

Summary: Yumex cannot detect a connected network with latest NetworkManager-0.8.997
Product: [Fedora] Fedora Reporter: Deji Akingunola <dakingun>
Component: yumexAssignee: Tim Lauridsen <tla>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: fred, mattia.verga, tla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: yumex-3.0.2-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-05 21:34:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Deji Akingunola 2011-03-28 13:50:00 UTC
Description of problem:
Yumex complains about "Not connected to an network" when starting it after having updated to NetworkManager-0.8.997-4.
Disabling network check in the program works around the issue.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim Lauridsen 2011-03-28 15:04:51 UTC
please run 'yumex -d ' in a terminal and paste the result in this report

Comment 2 Deji Akingunola 2011-03-28 15:20:11 UTC
I removed the option to 'Disable network check', and ran 'yumex -d';

>>
11:19:10 : DEBUG - Current Yumex Settings:
11:19:10 : DEBUG -     autorefresh: True
11:19:10 : DEBUG -     branding_title: 'Yum Extender'
11:19:10 : DEBUG -     bugzilla_url: 'https://bugzilla.redhat.com/show_bug.cgi?id='
11:19:10 : DEBUG -     color_install: 'darkgreen'
11:19:10 : DEBUG -     color_normal: 'black'
11:19:10 : DEBUG -     color_obsolete: 'blue'
11:19:10 : DEBUG -     color_update: 'red'
11:19:10 : DEBUG -     debug: True
11:19:10 : DEBUG -     disable_netcheck: False
11:19:10 : DEBUG -     disable_repo_page: False
11:19:10 : DEBUG -     history_limit: 15
11:19:10 : DEBUG -     plugins: True
11:19:10 : DEBUG -     proxy: ''
11:19:10 : DEBUG -     recentdays: 14
11:19:10 : DEBUG -     repo_exclude: ['debug', 'source']
11:19:10 : DEBUG -     typeahead_search: False
11:19:10 : DEBUG -     use_sortable_view: False
11:19:10 : DEBUG -     use_sudo: False
11:19:10 : DEBUG -     win_height: 600
11:19:10 : DEBUG -     win_sep: 300
11:19:10 : DEBUG -     win_width: 982
11:19:10 : DEBUG -     yum_conf: '/etc/yum.conf'
11:19:10 : DEBUG -     yumdebuglevel: 2
/usr/lib/python2.7/site-packages/guihelpers/__init__.py:256: GtkWarning: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
  self.add_from_file(filename)
11:19:10 : INFO - Not connected to an network
11:19:16 : DEBUG - Quiting the program !!!   <yum_backend.quit>
11:19:16 : INFO - yum backend process is ended
11:19:16 : DEBUG - Backend reset completed   <yum_backend.quit>
Program Terminated
<<

Comment 3 Tim Lauridsen 2011-03-29 10:51:41 UTC
*** Bug 691715 has been marked as a duplicate of this bug. ***

Comment 4 Tim Lauridsen 2011-03-29 17:52:53 UTC
Fixed upstream

pre-release is available here:

http://repos.fedorapeople.org/repos/timlau/yumex/

Comment 5 Fred 2011-03-30 03:52:43 UTC
I confirm it's working on my machine. Thanks.
What about this other trivial yumex string bug https://bugzilla.redhat.com/show_bug.cgi?id=691713, it's still there. 

I realize the description text could have been better though.

Comment 6 Fedora Update System 2011-03-30 07:55:20 UTC
yumex-3.0.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yumex-3.0.2-1.fc15

Comment 7 Fedora Update System 2011-03-30 07:55:43 UTC
yumex-3.0.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/yumex-3.0.2-1.fc14

Comment 8 Fedora Update System 2011-03-30 20:04:47 UTC
Package yumex-3.0.2-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yumex-3.0.2-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/yumex-3.0.2-1.fc14
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-04-05 21:34:22 UTC
yumex-3.0.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-04-07 18:52:21 UTC
yumex-3.0.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.