Bug 6919

Summary: rp3 and rp3-config segfault
Product: [Retired] Red Hat Linux Reporter: ashupp
Component: rp3Assignee: Nalin Dahyabhai <nalin>
Status: CLOSED ERRATA QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-07 12:53:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ashupp 1999-11-11 06:32:21 UTC
Upon startup both rp3 and rp3-config crash due to segfault.
I can provide core files if neccesary.  This started
happening immediatly after the upgrade to 6.1 from 5.2.
Both kppp and gnome-ppp work fine.

Comment 1 Michael K. Johnson 1999-11-18 23:43:59 UTC
If the errata release rp3-1.0.1 does not fix this for you, please try
ftp://people.redhat.com/johnsonm/rp3/rp3-1.0.2-1.i386.rpm

Comment 2 Michael K. Johnson 1999-12-09 00:53:59 UTC
I didn't hear back, but there are a few more bugs fixed in the latest test
release at
ftp://people.redhat.com/johnsonm/rp3/rp3-1.0.3-1.i386.rpm
If I don't hear back by the time I make an official errata release, I'll
assume that one of these two packages has fixed the problem.

Comment 3 ashupp 1999-12-09 06:26:59 UTC
Thanks, 1.0.2 fixed the segfaulting.  It now connects fine, but DNS doesn't work
corectly. Fix is trivial, but I suppose I'll open another bug though.

Comment 4 Michael K. Johnson 1999-12-09 21:47:59 UTC
Glad to know it is fixed.

Please don't open another bug report unless you have the latest initscripts.

Comment 5 Nalin Dahyabhai 2000-02-05 04:23:59 UTC
Which DNS problems were you referring to?  Have they been solved?

Comment 6 ashupp 2000-02-06 01:15:59 UTC
Yes, the new initscripts fixed the problem.  The problem was, as far as I could
tell, that /etc/ppp/resolv.conf was being created on connect, but not copied to
/etc/.  If I setup that file by hand, everything worked fine.

Comment 7 Nalin Dahyabhai 2000-02-07 12:53:59 UTC
Thanks for following up on this.  I'm tagging this bug as fixed by an errata.