Bug 705597

Summary: Installer in FC15 RC3 and Beta crash after selection "Basic Storage Devices"
Product: [Fedora] Fedora Reporter: Jonathan Vasquez <jvasquez1011>
Component: partedAssignee: Brian Lane <bcl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 15CC: bcl, hdegoede, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-18 17:48:49 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Anaconda log file
none
Program log file
none
Storage log file
none
Messages file in /var/log/
none
parted -l output none

Description Jonathan Vasquez 2011-05-17 18:27:32 EDT
Description of problem:
The installer (anaconda) crashes in Fedora 15 Beta and RC3 after selecting "Basic Storage Devices", click next, and displaying "Examining storage devices".


Version-Release number of selected component (if applicable):


How reproducible:
Very easy


Steps to Reproduce:
1. Open Installer
2. Select Language (U.S English) , NEXT
3. Select "Basic Storage Devices", NEXT
4. You will see "Examining storage devices", and then it will crash.
  
Actual results:
It just closes the installer and the mouse stays as if it was looking for something.

Expected results:
Proceed to next section that allows me to select custom partition layout.


Additional info:
The installer does not crash if you have an empty partition so it seems to be a problem with it reading LVM volumes.

My partition configuration is as follows:

/dev/sda1 /boot ext4 (for kernel to find LVM volumes)
/dev/sda2 LVM

inside LVM - system:

/dev/system/swap - 2gb swap
/dev/system/root - 10gb ext4
/dev/system/var - 10gb reiserfs
/dev/system/home - rest of disk (200gb) ex4

It's also not a problem with a mix of ext4 and reiserfs volumes because the installer also crashed in Fedora 15 Beta when I was using just ext4 volumes.

Crashes on:
Fedora 15 Beta
Fedora 15 RC3

If any additional information is needed, please ask.
Comment 1 David Lehman 2011-05-17 18:47:01 EDT
Please attach the following files so we can see why this isn't working for you. (It is working for most people.):

  /tmp/anaconda.log
  /tmp/storage.log
  /tmp/program.log
  /var/log/messages


Thanks.
Comment 2 Jonathan Vasquez 2011-05-17 19:06:35 EDT
Created attachment 499489 [details]
Anaconda log file
Comment 3 Jonathan Vasquez 2011-05-17 19:06:57 EDT
Created attachment 499490 [details]
Program log file
Comment 4 Jonathan Vasquez 2011-05-17 19:07:12 EDT
Created attachment 499491 [details]
Storage log file
Comment 5 Jonathan Vasquez 2011-05-17 19:07:30 EDT
Created attachment 499492 [details]
Messages file in /var/log/
Comment 6 Jonathan Vasquez 2011-05-17 19:07:53 EDT
I have attached the files you requested.
Comment 7 Jonathan Vasquez 2011-05-17 22:15:37 EDT
I have been doing some further testing and I tested out the RC3 in VirtualBox. I created a few lvm partitions prior to booting the installer and tried to run the Fedora installer. In the virtual machine the installer worked and found all the LVMs. So I'm not assuming that the problem isn't that the partitions have LVM volumes but it's something else. From the logs, it seems that there is come configuration missing.
Comment 8 David Lehman 2011-05-17 23:33:36 EDT
It looks like the removable USB drive contains a UDF filesystem which is causing parted to completely crash anaconda. Would it defeat the purpose of your install to remove it during installation?

I'd be curious to see the output of the command 'parted -l' run with the drive still present.
Comment 9 Jonathan Vasquez 2011-05-18 17:28:52 EDT
Created attachment 499699 [details]
parted -l output

Hmm, the usb is required because I'm installing Fedora via USB (created with Live USB Creator). So on /dev/sdb1 (the usb partition in my comp) is the only partition on the usb and it's W95-FAT32. 

Attached is the output of `parted -l`.
Comment 10 Brian Lane 2011-05-18 17:48:49 EDT

*** This bug has been marked as a duplicate of bug 704669 ***