Bug 704669 - Assertion (head_size <= 63) at dos.c:661 in function probe_partition_for_geom() failed.
Assertion (head_size <= 63) at dos.c:661 in function probe_partition_for_geom...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Reopened
: 705597 707203 707351 708601 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-13 19:24 EDT by Graydon
Modified: 2011-06-03 01:33 EDT (History)
6 users (show)

See Also:
Fixed In Version: parted-2.3-9.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-03 01:33:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graydon 2011-05-13 19:24:39 EDT
Description of problem:
parted cannot create partitions or read them from a new SSD, freshly installed in a laptop.  This prevents Fedora 14 or 15 from being installed.

SSD model number reports as "ATA INTEL SSD SA2CW12"

Version-Release number of selected component (if applicable):
parted-2.3-7.fc15.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. partprobe -s
2.
3.
  
Actual results:
[root@localhost ~]# partprobe -s
/dev/sda: msdos partitions
Backtrace has 12 calls on stack:
  12: /lib64/libparted.so.0(ped_assert+0x2e) [0x7f744f6b4a9e]
  11: /lib64/libparted.so.0(+0x3bf36) [0x7f744f6ddf36]
  10: /lib64/libparted.so.0(+0x3c31e) [0x7f744f6de31e]
  9: /lib64/libparted.so.0(+0x3e176) [0x7f744f6e0176]
  8: /lib64/libparted.so.0(ped_disk_add_partition+0x1a7) [0x7f744f6ba847]
  7: /lib64/libparted.so.0(+0x3d61b) [0x7f744f6df61b]
  6: /lib64/libparted.so.0(+0x3ee63) [0x7f744f6e0e63]
  5: /lib64/libparted.so.0(ped_disk_new+0x58) [0x7f744f6baca8]
  4: partprobe() [0x4011bb]
  3: partprobe(main+0x145) [0x400f65]
  2: /lib64/libc.so.6(__libc_start_main+0xed) [0x7f744e20d31d]
  1: partprobe() [0x400fb1]
A bug has been detected in GNU Parted.  Refer to the web site of parted http://www.gnu.org/software/parted/parted.html for more information of what could be useful for bug submitting!  Please email a bug report to bug-parted@gnu.org containing at least the version (2.3) and the following message:  Assertion (head_size <= 63) at dos.c:661 in function probe_partition_for_geom() failed.
Aborted (core dumped)



Expected results:
A partition listing

Additional info:
Trying to install using the Fedora 15 KDE live install from a USB key; the Fedora 14 version (KDE, LXDE, whole 3.2 GB DVD image...) boots fine, too, but has (apparently) the same install issue.  Tried 15 to see if whatever-it-was happened to be fixed in 15.

In both versions, I get to "this disk may need to be initialized" in the install and then I get either a hang-forever condition(14, straight into the installer) or the installer aborts(15, "Install to Hard Drive" option).

Laptop is a Lenovo X120e.

fdisk allows me to partition the hard drive in question; I can then put an ext2 file system on it, mount it, use touch to create a file, etc.
I get the same error from parted whether or not I've used fdisk to define a partition table or not; I do get "/dev/sda: msdos partitions 1" when there's a partition defined, rather than the blank listed above, which was run against no partitions being defined.

Since I understand anaconda to depend on parted, I think the installer problem is really a parted problem.

I've followed the parted error report request to report the bug upstream to GNU
Comment 1 Brian Lane 2011-05-13 19:53:48 EDT
This is caused by parted trying to guess the CHS geometry and failing. You can probably fix it by dd'ing the first 64 sectors of the drive and then re-partitioning it.
Comment 2 Graydon 2011-05-13 20:20:40 EDT
dd'ing in the sense of "write the first 64 sectors with zeros"?

Sorry to be slow; my strongest association with dd is as a means of copying drive contents exactly, and I'm not sure how that would help!
Comment 3 Graydon 2011-05-15 07:07:56 EDT
Much hammering away with dd, sfdisk, and cfdisk got me to an install-able state, and I have the release candidate for Fedora 15 on the laptop now.

cfdisk (but not fdisk or parted) reported an inital chunk of 1.05 MB of free space, marked bootable, before dd was used to write zeros to the whole drive.

partprobe -s failed right up to the point "install to hard drive" worked; I was in fact very surprised that the install worked because partprobe -s had failed.

So I've got a fix for my particular issue but don't know precisely what it was.

I'd also like to suggest that the install just quietly dying like that remains a meaningful bug.
Comment 4 Brian Lane 2011-05-18 17:48:49 EDT
*** Bug 705597 has been marked as a duplicate of this bug. ***
Comment 5 Brian Lane 2011-05-26 09:43:12 EDT
*** Bug 707203 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2011-05-26 19:18:14 EDT
parted-2.3-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/parted-2.3-9.fc15
Comment 7 Brian Lane 2011-05-27 15:18:01 EDT
*** Bug 707351 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2011-05-27 16:19:55 EDT
Package parted-2.3-9.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parted-2.3-9.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/parted-2.3-9.fc15
then log in and leave karma (feedback).
Comment 9 Graydon 2011-05-30 19:27:23 EDT
Works for me.  (partprobe -s runs and returns output that appears to be correct.)

Thanks!
Comment 10 Brian Lane 2011-05-31 09:47:15 EDT
Please don't close bugs. Instead leave feedback on the package at the link above so that it will get pushed to updates. Thanks!
Comment 11 Brian Lane 2011-05-31 12:07:21 EDT
*** Bug 708601 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2011-06-03 01:33:03 EDT
parted-2.3-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.