Bug 716140

Summary: FTBFS evolution-data-server-3.1.2-1.fc16
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: evolution-data-serverAssignee: Matthew Barnes <mbarnes>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: mbarnes, mcrha
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 716354 (view as bug list) Environment:
Last Closed: 2011-07-16 16:45:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 716354    
Bug Blocks: 713919    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2011-06-23 12:23:02 EDT
evolution-data-server-3.1.2-1.fc16.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 12:23:05 EDT
Created attachment 509120 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 12:23:07 EDT
Created attachment 509121 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 12:23:08 EDT
Created attachment 509122 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 12:23:11 EDT
Created attachment 509123 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 12:23:12 EDT
Created attachment 509124 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 12:23:14 EDT
Created attachment 509125 [details]
mock.log


mock.log for x86_64
Comment 7 Milan Crha 2011-06-24 01:56:13 EDT
As I wrote to the mailing list, this is because pango isn't ready for the deprecation of G_CONST_RETURN. From the build log:
> /usr/include/pango-1.0/pango/pango-renderer.h:252:1: error: unknown type
> name 'G_CONST_RETURN'

This is not available, because evolution-data-server defines couple deprecated flags:
	G_DISABLE_DEPRECATED
	PANGO_DISABLE_DEPRECATED
	GDK_PIXBUF_DISABLE_DEPRECATED
	G_DISABLE_SINGLE_INCLUDES
	GTK_DISABLE_SINGLE_INCLUDES
	GSEAL_ENABLE

Thus this is a transitive failure, due to a library which is not ready for the recent GLib deprecation.
Comment 8 Matthew Barnes 2011-07-16 16:45:35 EDT
Superceded by evolution-data-server-3.1.3-1.fc16.